Sign up ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

my Cassandra version is 1.2.4 and i'm trying to upgrade it to 2.0.5 and i know that in the first part i have to upgrade it to 1.0.14 and after that try to upgrade it to the 2.0.5 ,

when I try to run nodetool -h localhost removenode Host ID it gives me :

Exception in thread "main" java.lang.UnsupportedOperationException: Cannot remove self at org.apache.cassandra.service.StorageService.removeNode( .....

before running that command i tried nodetool upgradesstables

what is the problem ? and how can i resolve it ?

OS:Ubuntu 12.04 lts

share|improve this question
wait what ? upgrading 1.2.4 to 1.0.14 ? there is a typo ? – TheSquad Jan 22 at 18:59

1 Answer 1

is there multiple node on your cluster ?

if not, just drain the node and close it...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.