Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Earlier, I upgraded my website server to Ubuntu 14.04 LTS. I had a very nice setup with MariaDB and the TokuDB engine. However, the setup was kind of messed up when TokuDB refused to load properly, causing WordPress to display the install page because it could not read the database tables! Agh! (Hopefully they are still there...)

I disabled transparent hugepages (because they were enabled after the upgrade), but TokuDB still refuses to load, even when I followed the directions on the MariaDB website:

MariaDB [(none)]> install soname 'ha_tokudb';
ERROR 1123 (HY000): Can't initialize function 'TokuDB'; Plugin initialization function failed.

What else could be causing TokuDB to not load?

UPDATE: I have fixed the issue. You can read about it here: https://mariadb.atlassian.net/browse/MDEV-6165

share|improve this question

migrated from unix.stackexchange.com Apr 24 at 14:36

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

    
Did you follow the directions here? mariadb.com/kb/en/how-to-enable-tokudb-in-mariadb –  slm Apr 24 at 2:11
    
@slm Yes, I did. –  ascom Apr 24 at 11:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.