Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Please help me to start data management node. I have installed cluster with autoinstaller and it was working. Now i'm trying to change config (i want to change amount of DataMemory) and run cluster. I was trying to do it with simple restarting management nodes, it does not work. ndb_mgmd works with some other cache config file (ndb_node_config.ndb.bin.1) and i must run it with "--initial" to reload config (am i right?). I have deleted all files in management nodes directories except config.ini. Now i'm trying to start nodes with command

ndb_mgmd -f /home/user/MySQL_Cluster/49/config.ini --ndb-nodeid=49 --config-dir=/home/user/MySQL_cluster/49 --initial

and same command with 52 instead of 49 on another node (ndb_nodeid=49). I have running process on the first node, but not on the second. Log file on the first node looks like this:

2014-05-23 19:58:21 [MgmtSrvr] INFO -- Got initial configuration from '/home/ubuntu/MySQL_Cluster/49/config.ini', will try to set it when all ndb_mgmd(s) started 2014-05-23 19:58:21 [MgmtSrvr] INFO -- Id: 49, Command port: *:1186 2014-05-23 19:58:21 [MgmtSrvr] INFO -- MySQL Cluster Management Server mysql-5.6.17 ndb-7.3.5 started 2014-05-23 19:58:21 [MgmtSrvr] INFO -- Node 49: Node 49 Connected 2014-05-23 19:58:21 [MgmtSrvr] INFO -- Node 49 connected 2014-05-23 19:59:48 [MgmtSrvr] INFO -- Node 49: Node 52 Connected 2014-05-23 19:59:48 [MgmtSrvr] WARNING -- Refusing other node, it has different checksum: 0xf9205804, expected: 0xf9201802 2014-05-23 19:59:48 [MgmtSrvr] ALERT -- Node 49: Node 52 Disconnected

And here is part of config.ini: [NDB_MGMD DEFAULT] Portnumber=1186 [NDB_MGMD] NodeId=49 HostName=192.168.56.201 DataDir=/home/user/MySQL_Cluster/49/ Portnumber=1186 [NDB_MGMD] NodeId=52 HostName=192.168.56.202 DataDir=/home/user/MySQL_Cluster/52/ Portnumber=1186

So, how there might be expected checksum if i have deleted all files? And how can i fix it? I can't find any information on this in documentation.

UPD: I don't know what the matter, but now it's work. I just have started cluster again with autoinstaller and have not removed files from config dir. Now it's starting with ndb_mgmd -f /home/user/MySQL_Cluster/49/config.ini --ndb-nodeid=49 --config-dir=/home/user/MySQL_cluster/49 --initial and same command with 52 instead of 49 on the second node.

May be somebody have some additional information about starting management nodes (for example, how they estimate and store checksums)?

share|improve this question
1  
I'm getting the same "different checksum" error when trying to set up a fresh cluster where I accidentally installed different minor versions of MySQL cluster on management nodes ... –  Hartmut Holzgraefe Dec 15 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.