Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Please see the following link from Super User. I cannot get anything working:

http://superuser.com/q/342609/93569

Update: This link has been dramatically changed! Please see the link.

share|improve this question

closed as not a real question by jcolebrand Oct 19 '11 at 17:53

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have posted an answer at the link you have provided. Check it out. –  dabest1 Oct 19 '11 at 1:59
    
I posted what to do with the InnoDB log files –  RolandoMySQLDBA Oct 19 '11 at 11:42
3  
not a fan of the way this quesiton was asked. I'm not going to click a link to superuser to read a question. –  Derek Downey Oct 19 '11 at 17:48
    
If the OP or anyone else wants to edit the question to be an actual question and have this question reopened, they are welcome to, however, this is not acceptable, never has been on the Stack Exchange network, and is generally answered at the provided link, thus requiring no or little input here. –  jcolebrand Oct 19 '11 at 17:54

4 Answers 4

On Debian or Ubuntu you can also do this on the command line to login as the administrator:

sudo mysql --defaults-file=/etc/mysql/debian.cnf

Then you reset the password as randy has indicated.

share|improve this answer
    
I'm using Windows. –  Dynamic Oct 7 '11 at 23:32

Your innodb_log_file_size is set incorrectly, so InnoDB isn't starting up. You haven't even gotten to the part where the password reset would matter.

share|improve this answer

It's very simple if you can restart your MySQL daemon.

Simply add 'skip-grant-tables' to your mysql configuration file (*nix: /etc/my.cnf). http://dev.mysql.com/doc/refman/5.0/en/server-options.html#option_mysqld_skip-grant-tables

Then, get into mysql:

mysql -u root

Next, reset your password:

SET PASSWORD FOR user = PASSWORD('Passw0rd');

Finally, remove the 'skip-grant-tables' from your configuration and restart mysqld.

For an extended level of verbosity, see Rolando's answer: Stuck outside MySQL! XAMPP - help please

share|improve this answer

I have posted an answer at the link you have provided, with the following info:

In your case, before you can even reset the password, you need to fix the start up issue.

Note the first error listed in MySQL error log:

InnoDB: Error: log file .\ib_logfile0 is of different size 0 5242880 bytes
InnoDB: than specified in the .cnf file 0 24117248 bytes!

This means that you may have copied your database files from another location or you have edited my.cnf settings and they no longer match the real ib_logfile0 file size. Focus on this issue first.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.