Sign up ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am having trouble setting up the Oracle Wallet on a new box connecting to a new database. I have added the following lines to my SQLNET.ORA:


The wallet is created without error, the credentials added, and I can list the credentials back from the wallet without a problem, but when I go to use them I get an ORA-12578 as follows:

C:\oracle\Wallet>sqlplus /@MYDB

SQL*Plus: Release Production on Mon Oct 31 16:57:53 2011

Copyright (c) 1982, 2010, Oracle.  All rights reserved.

ORA-12578: TNS:wallet open failed

I am on a 64 bit box using the 32 bit 11.2 client to connect to an 64 bit 11.2 database. Logging in without the wallet works fine. The error message indicates that I should turn tracing on. I have done so, but don't see anything obvious. Does anyone have a suggestion before I contact Oracle support?

share|improve this question
See this link /Danny –  user4985 Dec 8 '11 at 15:52
I didn't see the problem based on your link, but it did give me a chance to tackle the problem again. See my answer for the strikingly simple and obvious answer. –  Leigh Riffel Dec 8 '11 at 22:31
I had the same issue. After removing a space in the sqlnet.ora before the entry WALLET_LOCATION solved the problem for me. " WALLET_LOCATION" -> "WALLET_LOCATION" –  user37215 Apr 17 '14 at 8:43

1 Answer 1

up vote 1 down vote accepted

I was able to figure out from the trace file that there was line in the sqlnet.ora file that it didn't like. I narrowed it down to the WALLET_LOCATION line and finally recognized that there was a missing parenthesis at the end of the line.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.