Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I tried to set up 3 SQL instances, one publisher 2 subscribers, to replicate data between them.

I did it using the GUI wizard and all went fine in the Publisher: my publication appears under "Local Publications" and if I expand it, it lists the 2 subscriptions of the other 2 instances.

But in the 2 instances, the subscription does not appear under "Local Subscription". If I try to do it again, it tells me the subscription already exists..

How can I get the 2 subscribers to appear under 'Local Subscription' and make transactional replication work?

share|improve this question

closed as too localized by jcolebrand Feb 24 '12 at 3:52

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Ragna, are these push or pull subscriptions? You can find out by going to Replication -> Local Publications -> Right Click on the Publication -> In Publication Properties Under Subscriptions Options: Check to see if Allow Pull Subscriptions is True or False. –  Craig Efrein Dec 1 '11 at 9:48
    
sp_helpSubscription @publication= 'nameofthepublication' or without @publication to list all publications. A subscription type of 0 is push, 1 is pull, 2 is anonymous. –  Craig Efrein Dec 1 '11 at 10:05
    
RagnaRock you still around? We would love to document this for the next guy coming down the pike, but you seem to have lost the desire to give us feedback. In lieu of your giving us more information, I'm gonna close this question in the future. –  jcolebrand Feb 16 '12 at 15:16
    
@jcolebrand I never looked to this again... I wasnt able to solve it. I've probably just removed everything and tried again and eventually got it working –  RagnaRock Feb 23 '12 at 14:41