Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have a an SQL server that normally listens on a private IP address (10.x.x.x). However, I would like to be able to connect to the database over the public (31.x.x.x). I tried to enable this tonight, but when I restarted the SQL Server service, the server wasn't listening on the internal IP address any more.

I was using the configuration manager to let the SQL Server know the IP addresses it should be listening on.

I am running SQL Server 2008R Standard.

share|improve this question
    
Is the public IP configured on one of the NIC cards of the server? –  Shawn Melton Nov 21 '11 at 1:11
    
Yes, it just seemed to happen after I'd configured it to listen on two IPs (the private one and the public one) –  Piers Karsenbarg Nov 21 '11 at 10:14
add comment

1 Answer

On the Protocol tab of configuration manager, there is a "Listen All" option, make sure that is set to yes.

Keep in mind that having an active listener on a public connection is asking for trouble, best to do it over a VPN, or filter allowed incoming connections by IP address, or at least use something other than the default port.

share|improve this answer
    
I've got Windows firewall running and locking it down by IP. –  Piers Karsenbarg Nov 22 '11 at 17:27
    
Also, I've already got Listen All set to yes –  Piers Karsenbarg Nov 22 '11 at 17:28
    
Stop and start SQL service if you haven't. Check the SQL Logs in management studio from the last startup, it will list the IP addresses it is listening on. Also check netstat -an –  SqlACID Nov 22 '11 at 18:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.