Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed SQL Server Express 2008 on my Windows 2003 server.

The sql base is started, but I look in config manager and my SQL Server browser is not started. I can't start it. When I try to change properties, I got an error: there's no enable device associate (0x800704).

I will look for reinstalling SQL Server browser manually ( ). I don't know if that will cause an error. Maybe the same thing I got before.

I try to reinstall/repair, but there's an error (my biggest problem is that I'm not the admin of this server, so I need to wait for the tech to be there if I want to do something. Last timed, I didn't have the time to get all information. I need to get all ideas and program before, because I will have not so much time to try to repair it. The server is used by other users (data), and I can't reboot often)

If you have any idea, what should I do, or Test, or hit?

thank you

share|improve this question
Do you really want to enable the Browser service? All it does is publish that the SQL Server is on the network. It's disabled by default for security reasons. – HardCode Nov 23 '11 at 20:34
I need to connect to the db from local network. And for the moment I cant, I was thinking that its the browser who do that. – forX Nov 25 '11 at 17:01
up vote 1 down vote accepted

To install SQL Sever properly -- and have all the services running as expected -- you really should be logged in as an administrator.

share|improve this answer
I was log as admin (in install mod). I did not have any error before I try to change sql server browser. (otherwise sql connection error, thats probably because the sql server browser is off) – forX Nov 23 '11 at 18:20
After retry to restart the sql server browser I finally found a way, just som little thing to change. I didnt have much time when I install (and I never really touch the computer, I dont have the right) – forX Nov 29 '11 at 20:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.