Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

We run a server with MySQL 5.5. 95% of the tables are set to the InnoDB engine.

However whenever I look at the my.ini file (using the MySQL Workbench) under mysqld section innodb is unchecked and OFF is selected in the drop down. I don't see this line added to the my.ini file when viewing with notepad.

Should I check this setting and set it to ON so we can utilize the enabled innodb settings (buffers & log file etc.) or does this not matter?

Thanks

share|improve this question
    
Currently if you download mysql 5.5.19 RPM's (source included) for linux generic INNODB is not available. Inspecting source RPM file WITH_INNOBASE_STORAGE_ENGINE is not on. [SOLVED] No InnoDb was caused my invalid innodb files due to changing innodb related files settings (on my.cnf) with the server running. –  ruionwriting Jan 3 '12 at 11:27
add comment

1 Answer

up vote 4 down vote accepted

Sounds like an issue with MySQL Workbench.

MySQL 5.5 has a default storage engine of InnoDB.

In fact, the option default_storage_engine is predefined as follows:

  • MySQL 5.5.4 and prior, MyISAM
  • MySQL 5.5.8 and after, InnoDB

There is another option called storage-engine, which was deprecated as for MySQL 5.5.3. Keep in mind that MySQL 5.5.8 was the very first GA release.

I would strongly suspect MySQL Workbench if it is coded to check storage-engine instead of default-storage-engine. This would allow MySQL Workbench to monitor older release of MySQL.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.