Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have sucessfully installed the Microsoft® SQL Server® 2008 Management Studio Express from the following link: http://www.microsoft.com/download/en/details.aspx?id=7593 file name: SQLManagementStudio_x86_ENU.exe

When I opend the MS SQL Server Management Studio, it asks for the Server Name which I am not sure what it is nor the login name and password.

Can someone please explain?

Thanks much!

share|improve this question

migrated from stackoverflow.com Dec 2 '11 at 1:05

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 5 down vote accepted

The server name (and instance name) for SQL Server Express by default would be localhost\sqlexpress (or .\sqlexpress, or yourMachineName\sqlexpress, or x.x.x.x\sqlexpress, where x.x.x.x is your machine's IP address). That is provided two things:

  1. You on the machine that houses the database engine
  2. You kept the defaults for SQL Server Express installation to make it a named instance, named SQLEXPRESS

As for the login. Most likely if you just installed it, select Windows Authentication and try to connect. I'm guessing you have added your account as SA priv. Did you create an sa account during installation? If so, and you enabled Mixed Mode authentication then you can log in with the sa credentials you created initially.

share|improve this answer
    
Thanks Shark! Here is the instruction from this youtube link wich i got confused at 4:49 (when the server name was entered) youtube.com/watch?v=7whqA-VZaYc –  Hung Captain Dec 2 '11 at 0:39
2  
@HungCaptain That guy just had a default instance, which is why it looked like he only typed in the server name. For the default instance, you connect with just the server name. For a named instance, it is the servername\instancename. –  Thomas Stringer Dec 2 '11 at 0:42
    
thanks once again. I am not very good at this. So what exactly did he entered in the server name, login info, and password? Sorry for asking not too smart questions –  Hung Captain Dec 2 '11 at 0:46
1  
@HungCaptain These aren't bad questions. For servername, put in this verbatim: localhost\sqlexpress. For login info, select Windows Authentication and then that's it. Hit connect. –  Thomas Stringer Dec 2 '11 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.