Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I just got my Hamachi VPN set up. For anyone familiar with Hamachi, I have it set up as a gateway so I'm part of the network when I'm away. Almost everything seems to be working perfectly. I can even backup using Windows Home Server if I want.

I cannot connect to my SQL Server from SQL Server Management Studio. Of course, when I'm at home, everything works perfectly. I can communicate with the database server just fine remotely (i.e., ping). I just can't connect with SSMS. The network configuration is at the default (TCP Enabled).

Does anyone know

  • Why I can't connect?
  • How I can determine why I can't?

Extra info:

  1. Using a Workgroup, not a domain.
  2. Using port 1433 to connect
  3. Connecting to the default instance
share|improve this question
    
Can you telnet to the SQL Server on port 1433? If not there's a firewall that's blocking you. –  mrdenny Dec 8 '11 at 22:53

2 Answers 2

Dear please visit this site i hope it would help you i was also looking for connecting with vpn but this web help me i hope it would help you also :)

http://www.sixbitsoftware.com/docs/webhelp_prohh/Sharing_a_Database_Over_a_Virtual_Private_Network_%28VPN%29.htm

share|improve this answer
1  
This answer needs improvement. Don't post only a link, links will (or may) be eventually broken. Describe what you (or the link) proposes. –  ypercube May 6 '13 at 21:13

Have you allowed remote connections in Surface Area Configuration -> Services and Connections -> Remote Connections?

I haven't specifically tried recently, but I have enabled TCP & Named pipes. You can also force a protocol if you need to, e.g. in the server name, use NP:myserver in order to force named pipes, or TCP:myserver in order to force TCP.

Try enabling named pipes in the connection setup too - client and server.

Also, hamachi normally uses its own IP range, so you should check that you can actually telnet to port 1433 of your server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.