Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have installed mysql using the package management system.I am using ubuntu machine.

After that i have very well configured the server for InnoDB and other server related parameters.

I am using the version

mysql> select version();
+-----------------------+
| version()             |
+-----------------------+
| 5.1.49-1ubuntu8.1-log |
+-----------------------+
1 row in set (0.00 sec)

Now i want to upgrade my MySQL server to some Higher version say 5.5. what steps should I follow to accomplish the same...?

Thanks...!

share|improve this question

1 Answer 1

up vote 2 down vote accepted

There's a PPA that someone has created which includes MySQL 5.5. Since PPA's are community-contributed, the usual warnings about using with caution apply.

There is a guide in the MySQL docs for some standard practices to follow when upgrading from one version level to another.

Edit:

Here is some information from the mysql_upgrade manual page that should give you an idea of why it's important. This is in response to your comment.

mysql_upgrade examines all tables in all databases for incompatibilities with the current version of MySQL Server. mysql_upgrade also upgrades the system tables so that you can take advantage of new privileges or capabilities that might have been added.

mysql_upgrade should be executed each time you upgrade MySQL. It supersedes the older mysql_fix_privilege_tables script, which has been removed in MySQL 5.5.

If mysql_upgrade finds that a table has a possible incompatibility, it performs a table check and, if problems are found, attempts a table repair.

share|improve this answer
    
I am really unable to understand how i will include the PPA.what is the importance of it..?? –  Abdul Manaf Dec 21 '11 at 13:10
    
what is importance of mysql_upgrade script..?? –  Abdul Manaf Dec 21 '11 at 13:11
    
@AbdulManaf, see my edit for information on mysql_upgrade –  bhamby Dec 21 '11 at 21:45
    
should I use mysql_upgrade after mysqld_safe? what is the best practice? –  maniat1k May 23 '12 at 16:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.