Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Two weeks ago I asked "How do I configure Windows XP to start the postgresql demon after each boot/reboot?", and BenV helped me out with his answer:

Make sure the service is set to start automatically.

  • Start->Control Panel->Administrative Tools->Services
  • Find the service (should be named something like postgresql-9.0)
  • Make sure the Startup Type is set to Automatic

Additionally there was a problem with the password for the user postgres that I had to correct, and everything worked fine - until the 2nd reboot (I installed PostgreSQL on my developer PC, which I switch off every night). I had to correct the password again, and have to redo it ever since after every 2nd reboot.

What can I do?

share|improve this question
    
So is the problem with the password or the installation/configuration of the service? –  jcolebrand Jan 28 '11 at 1:00
    
@jcolebrand: The problem is that the service "postgres" is set to automatic, but doesn't start automatically after the 2nd reboot (after the first it does). Logged in as administrator one can start the service only after reinserting the password, which seems to be forgotten by Windows. Where the problem comes from, I have no clue. –  j.p. Jan 28 '11 at 8:00
2  
The problem you describe sounds like the SF guys would be better suited to help you. This isn't a db problem, it would seem, but a windows issue. –  jcolebrand Jan 28 '11 at 8:01
add comment

1 Answer 1

There's also one more setting to be noted... On the same window where we set Automatic/Manual start up, there's a "Recovery" tab in which we can force the service to restart when a failure occurs.

But this might not be a good idea to use, especially on development environments, since it may help slip some possible problems past the developer's and/or administrator's eyes.

share|improve this answer
    
Thanks for the answer. I had set the server to automatically restart once if it fails, but this doesn't help. I guess I'll ask the guys at sf eventually. –  j.p. Feb 7 '11 at 14:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.