Tag Info

Hot answers tagged

6

Easily solved: export ORACLE_HOME=/usr/lib/oracle/12.1/client64 export PATH=$ORACLE_HOME/bin:$PATH export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$LD_LIBRARY_PATH Stick those lines in your ~/.bash_profile if you want them to persist for a given user, or in /etc/bashrc to persist for all users.


6

What was wrong with the answers on those two questions? They were 100% accurate, so I'm not sure what more we can do to help you here. I would suggest that you confirm that you never assume that you're in a transaction. Always check to make sure you are. In TSQL it would be as simple as checking @@TRANCOUNT to be greater than 0. That's rather the same as ...


5

I don't know about good.. but sqlplus run in rlwrap which makes it use readline is somewhat decent for a commandline app.


5

Check this question on Stackoverflow, you will have some idea. I use the client provide by Mysql itself, it's maybe not the best, but I can get my job done with it


4

If you only need to run SQLPlus, grab "Instant Client Package - Basic" and "Instant Client Package - SQL Plus: Additional libraries and executable for running SQL Plus with Instant Client" from http://www.oracle.com/technetwork/topics/linuxsoft-082809.html & install them. oci.dll is a windows file, so I have no idea what could be achieved by installing ...


4

Based on a_horse_with_no_name's comment, I started searching around psql and found the solution: \set VERBOSITY verbose SELECT * FROM tgvbn(); ERROR: 42883: function vfjkb() does not exist ... Now that goes into .psqlrc. Details and further options can be found in the psql documentation.


3

I have experience this exact same thing in the past. It usually happens because you have linked psql against an inferior readline-like library. If you are using libedit, use libreadline instead. If you are using libreadline, use a different one. Details depend on your operating system and method of installation.


3

For JDBC based tools such as Squirrel you should try to use (even with Oracle8i) a 9.x or even a 10.x driver (not sure about the 10.x though). Maybe they give better performance. Somewhere on the JDBC download page of Oracle there is a compatibility Matrix that shows which driver version is compatible with which database version. Another cross-platform ...


2

The public link below gives an overview of the four installation type options for the 11gR2 client: http://docs.oracle.com/cd/E11882_01/install.112/e24322/install_overview.htm#LACLI1245 Instant Client: Enables you to install only the shared libraries required by Oracle Call Interface (OCI), Oracle C++ Call Interface (OCCI), Pro*C, or Java database ...


2

You could live quiet safety with two ORACLE_HOMEs if you know: %TNS_ADMIN% is your tnsnames.ora / listener.ora / sqlnet.ora directory for both; in your %PATH% you should specify the right order for your preferred oracle bin; there's a Oracle_home_selector installed somehere (I don't remember) in full client install take a look at Windows Registry ...


2

The remote database has compatibility level 80, which doesn't work with db_id(). More info on a related StackOverflow question. (Just dumping this into an answer from the question comments so it disappears from the Unanswered list of questions.)


2

You can install it via Homebrew brew install mysql This will install the mysql deamon and the cli tool.


2

It's not clear from your question what brand of database you are connecting to. I will assume it's Oracle. You need this information: name of the server the database is on name of the database --sometimes called a service name is the database parameter db_domain configured with a value? (usually the domain name) the port the database listener is using ...


1

Well, sort of. In vim, save your work to a different file... :w myfile.sql [enter] Then exit vim with an artificial error so the mysql client won't bother to re-read the temporary file. :cq [enter] Then clear the input buffer in mysql. \c [enter] Then do what you've gotta do. Then re-launch vim \e [enter] The editor will have your last command ...


1

This package actually also installs the command-line interface (CLI) for MySQL, but does not put it in your $PATH. The solution is to first run the two commands below in a terminal: $ echo "export PATH=$PATH:/usr/local/mysql/bin" >> ~/.profile $ source ~/.profile Then you can use the CLI as explained here.


1

MySQL installs the database engine. Which you run and start from the terminal/bash/shell. You will need to download the MySQL workbench for a GUI. phpmMyAdmin is another choice which runs in the browser. Sounds like you have MySQL installed. You just need to setup a GUI now. Q1. why until now there's nothing in the applications? I can't see any item ...


1

Why not create a VIEW? The upside is that it is client independent.


1

Try changing the query to force a value Instead of SELECT id FROM table WHERE id=${LOOKUP} you can use SELECT COUNT(1) FROM table WHERE id=${LOOKUP} Here is bash script to use that new query LOOKUP=123 SQLSTMT="SELECT COUNT(1) FROM table WHERE id=${LOOKUP}" RCOUNT=`mysql -u... -p... -AN -Ddbname -e"${SQLSTMT}"` if [ ${RCOUNT} -eq 0 ] then echo ...


1

Did you control PATH Environment Variable to which comes first, 32 or 64. Which ever client is installed last, change PATH accordingly. I have encountered similar issue. Windows uses PATH environment variable to decide which dlls to load. I have two clients installed in my machine and used PATH variable to force which one to use. ...


1

It turns out that there's a simpler answer than I'd previously suggested: When starting the mysql client, use the --disable-reconnect flag. The original problem stemmed from the mysql command-line client's bizarre default behavior of automatically reconnecting and sending the given command, no matter how potentially harmful, if the connection has been lost. ...



Only top voted, non community-wiki answers of a minimum length are eligible