Tag Info

New answers tagged

5

PostgreSQL relies on the operating system's disk cache for most caching. This cache is usually reported as "free" RAM by most tools, because modern operating systems use all but a little bit of the currently-free RAM for disk cache. This is normal. To confirm, use a better tool that shows buffers/cache separately from truly free memory. On Linux, free -m ...


1

Based on your configurations and output, the only suggestions I can make for you to try are the following. Disable Transparent Huge Pages. Evidence from the PostgreSQL mailing lists, and Red Hat themselves recommend disabling THP for database workloads here Set vm.zone_reclaim_mode=0. Discussion here Set your elevator to deadline from cfq. Red Hat ...



Top 50 recent answers are included