New answers tagged

1

Naga this error would be where I would start looking SQLServer Error: 27, Registry information is corrupt or missing.Make sure the provider installed and registered correctly. [SQLSTATE 08001] If you are able to a repair of the installation should resolve this.


2

Set the SQL Agent service to Automatic(Delayed). The first thing it will do is try to connect to SQL Server, and if SQL Server hasn't finished starting yet, SQL Agent can fail. Delaying the start for SQL Agent will give SQL Server the chance to finish.


0

Make sure the SQL Agent service user (the one in services.msc) is a valid login on the SQL Server instance. If it is, look for 18456 errors in the SQL log to see why that login can't log in. Specific details in the MSDN Select an Account for the SQL Server Agent Service article


0

Select a valid user account on installation and the correct password instead of NTUSER/LOCAL and that's it. Preferably select also WINDOWS/SQL_SERVER ACCESS.


5

I found the problem: The installer I had was just for SQL Server Management Studio, as @MarkSinkinson pointed out. If you have this same problem, verify you have the correct installation file (not SSMS only, or an incompatible Edition). Other helpful things to check, from comments originally left on the question: You may have multiple instances ...


0

@Nissanna, As you said, you are getting the error during cmd installation of sql server express 2012. The syntax of argument "/HIDECONSOLE" is incorrect;Either the delimiter '=' is missing or there is one or more space characters before the '='" Error 0x84B40001 when you are running this syntax: SQLEXPR_x86_ENU.exe /ACTION=Install /HIDECONSOLE ...


1

edited answer based on the comments. For a basic setup here are a few things that I do before getting to the actual SQL install Have two additional IPs / Host Names in mind for the Windows Cluster and the SQL Server VIP Have two Domain service accounts setup for the Engine and the Agent (Something like DOMAIN\sql.eng.svc and DOMAIN\sql.agt.svc) Enable the ...


1

This is how I alter TCP to use a specific port including enabling TCP at the end -- You have $Tcp.IsEnabled = $false is that correct? [system.reflection.assembly]::LoadWithPartialName("Microsoft.SqlServer.Smo")|Out-Null $mc = new-object Microsoft.SqlServer.Management.Smo.Wmi.ManagedComputer . $Instance = $mc.ServerInstances[$InstanceName] #Change TCP Port ...


2

You were right about the pid. Adding /PID="11111-00000-00000-00000-00000" to command line helps. I had to search through the whole setup directory with RegEx -(.{5}|.{11})- and try everything I found. The right pid was in the file Microsoft.SqlServer.Configuration.SetupExtension.dll at address 000f68f4 (for SQL Server 2014 x64 setup media).



Top 50 recent answers are included