Tag Info

Hot answers tagged

6

Bit late to the party on this one... The database should register with the listener automatically, making the SID_LIST entries redundant, and this seems to be happening with your 192.168.111.111 environment. If the listener is started after the database it can take a while for it to register, and there may be situations where it doesn't do so at all. You ...


4

Run: lsnrctl status LISTENERNAME ... where LISTENERNAME is the name of the listener that is listening on port 1531. You can get this name from your $ORACLE_HOME/network/admin/listener.ora file. For example: LISTENER1531 = (DESCRIPTION_LIST = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = node1)(PORT = 1531)) ...


3

The description for the message you're seeing is: Cause: Most of the listener administrative commands are only intended to be issued by privileged users, for example DBAs or system administrators. If the listener password is not set, then the listener only accepts administrative requests from LSNRCTL running with the same OS credentials, or ...


2

This is the default behaviour. As long as you don't have the default service in your tns_aliasses that are in use it should not be a problem.


2

dbstart will only start databases that have the third parameter in the oratab file set to Y. Check the value in that file. You also don't need to pass the ORACLE_HOME as an argument; not sure if you actually meant to pass the SID, but anyway, the home is taken from the oratab too. The script itself says that it should only be executed as part of the system ...


2

Try this: COTT3 = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = COTT3) ) ) If that doesn't work, replace "SERVICE_NAME" with "SID". Put this in $ORACLE_HOME/network/admin/listener.ora: LISTENER = (DESCRIPTION_LIST = (DESCRIPTION = (ADDRESS_LIST = ...


2

So, with thanks to @YasirArsanukaev for the time he put in, I have found a solution which works, but which I can't really explain. Riffing on the LOCAL_LISTENER thought, I was reading this other answer where it said: The database uses the LOCAL_LISTENER parameter to identify the listener it should register with. By default that is null, which ...


1

To me it looks like you did not start the listener but it is started. Your problem seems to be the tcp connection and not the ipc. So the listener is running, you can not reach it using tcp. Test this using telnet gaurav 1521 If the telnet does not give a connection, a firewall is blocking you. Stop/edit the firewall.


1

The documentation explains how to go about configuring listener tracing, but in summary: Add: TRACE_FILE_<LISTENERNAME>=listener.log TRACE_DIRECTORY_<LISTERNAME>=/path_to_your_log_directory TRACE_LEVEL_<LISTENERNAME>=user You can up the TRACE_LEVEL to admin or support if you need more information, but be aware that they generate ...


1

(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521))) You have the localhost ip in the listener.ora (127.0.0.1), change this or add another line with the NIC ip.


1

11g Oracle recommends that we configure the EXTPROC by altering the extproc.ora file rather than configure the listener for Oracle 11g. The extproc.ora file is located in the ORACLE_HOME\hs\admin directory.


1

There are a few problems. 1) given the fact that you specified local_listener, you want your database instance to register to a non default listener for which the tnsalias should be LISTENER_OTRS 2) the tnsalias LISTENER_OTRS is missing 3) the tnsalias otrs is misformed (it has multiple addresses but not the ADDRESS_LIST parameter (in this case, the last ...


1

As Phil Says I replaced hostname with Actual IP but the connection prblem was for (PROGRAM = extproc) In listener.ora file, Removing it solved the issue. To let external procedures work these changes should be done: Adding new SID entry in SID_LIST_LISTENER SID_LIST with SID_NAME = SID in tnsnames.ora at EXTPROC_CONNECTION_DATA and PROGRAM = extproc ...


1

The windows error 54 is associated with a port busy or problems with the network communication, try editing the listener.ora file and change the port, then restart the listener service (or if you're able to restart the machine, do so). It looks like that, for some reason, the port 1521 hungs and there's no longer a TNS Listener service listening there. ...


1

assuming that your Oracle software is installed in F:\Oracle: set ORACLE_HOME=F:\Oracle set PATH=%ORACLE_HOME%\bin;%PATH% lsnrctl start should do the trick. If you work with Oracle, make sure that the environment is setup correctly. Also note that if you have multiple Oracle installations on the same Windows machine, the PATH is modified such that the ...


1

As a quick fix, you can just remove the entries (with respect to your database)from both the tnsnames.ora and listerner.ora. In your scenario, remove this from tnsnames.ora PROJECT = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = admin-xxxxxx)(PORT = 1521)) ) (CONNECT_DATA = ...



Only top voted, non community-wiki answers of a minimum length are eligible