Tag Info

New answers tagged

1

Which version are you using? 5.6.? I did however came across this bug, hopefully it helps. http://bugs.mysql.com/bug.php?id=68287


0

Your per-connection buffers are too high. Look at the mysqltuner.pl output. It says 736.1M per thread. This has the greatest impact on the 220GB Estimate. How ? join_buffer_size is 32M sort_buffer_size is 256M read_buffer_size is 64M read_rnd_buffer_size is 384M The sum of these is 736M Multiplying this by max_connections (which you have set at 300) is ...


0

A few ideas: Turn query cache off (reduces that usage to 0). Doesn't appear to be a big win for you, so it's an unnecessary performance hit (in addition to the memory usage). Unless I’m reading the report wrong, you don’t appear to have a lot of MyISAM tables. I’d reduce read_buffer_size to the default (128K) and read_rnd_buffer_size to the default (256K). ...


0

My first question where are you looking for SQL Server memory consumption. Please don't use task manager or process monitor, these do not show correct value when SQL Server service account has Locked pages in memory privilege. just use below query to see memory consumed by SQL Server select (physical_memory_in_use_kb/1024)Memory_usedby_Sqlserver_MB, ...


0

Start by looking at the min server memory and max server memory configuration options detailed at http://msdn.microsoft.com/en-us/library/ms178067.aspx. You can pull them up by running: exec sp_configure 'min server memory' exec sp_configure 'max server memory' Ultimately, you have to decide if performance is being affected by these settings or not.


0

:) If you are interested for the detailed instructions please see below. It works instantly without the need for SQL restart! http://msdn.microsoft.com/en-gb/library/ms178067.aspx Use the two server memory options, min server memory and max server memory, to reconfigure the amount of memory (in megabytes) managed by the SQL Server Memory Manager for an ...


0

http://www.brentozar.com/archive/2012/06/sql-server-max-memory-myths-video/ has some background why MAX memory should be set. 2012 starts to get covered in the middle of the video.


0

I don't think DBCC MEMORYSTATUS (or the other queries) are being that revealing at the moment (don't know what the others think); so I am going to ask you to run just one more: dbcc traceon(3654, -1) go waitfor delay '00:05:00' go select top 20 memory_object_address, source_file, sum(size_in_bytes) as total_bytes from sys.dm_os_memory_allocations group by ...


1

x86-64 Virtual Address Space Details: Although virtual addresses are 64 bits wide in 64-bit mode, current implementations (and all chips known to be in the planning stages) do not allow the entire virtual address space of 264 bytes (16 EB) to be used. This would be approximately four billion times the size of virtual address space on 32-bit machines. ...


2

Some details to clear things up Based on that msdn page : server memory settings it's a good practice to keep the default values for SQL-Servers min and max memory to keep it dynamic. No, its not written its a good practice its said its recommended and I am sure MS books online cannot write it as good this because of fact that its always good to have ...


0

There is nothing wrong in Available Virtual Memory is 8,763,135,270,912. This number is at least 8TB actually starting from SQL Server 2012 this new feature has been introduced in SQL Server 2012 DBCC MEMORYSTATUS output. Below is output of memorystatus on my system Process/System Counts Value ---------------------------------------- ...


2

The MIN value is useful when you have a server with multiple instances. You can use it to prioritise memory usage per instance. But mainly it is to guarantee that SQL with have at least that much memory to work with. This stops people running something on the server and stealing all the memory. The default setting basically leaves memory allocation to SQL ...


0

If your mysql is on dedicated server then you can set the buffer pool to the value 4GB. Initially the queries will run little slow because they require disk seeks. As your data set is very small so you can keep most of the data in memory. Once the data is present in memory performance will increase. As your server is having huge number of reads and less ...


0

shared_buffers is the statically allocated shared cache all PostgreSQL backends share. in addition to this, each back-end has private memory which it uses for query plans, query text, prepared statements, cursors, and much more. It also has some query working memory, controlled by work_mem, which is used for in-memory sorts/joins/etc, and has ...


2

shared_buffers are statically taken at startup and are never resized. effective_cache_size is just a hint to the optimizer. it is never allocated. it merely gives a hint of what is going on. so shared_buffers is what you see as taken.



Top 50 recent answers are included