Tag Info

New answers tagged

0

Martin Smith's comment ("Does the subquery itself work?") was ultimately the answer and highlighted my insufficient forensic work! ;-) The subquery was returning ROW COUNTS from tables: ... INNER JOIN sys.dm_db_partition_stats AS ddps ON i.OBJECT_ID = ddps.OBJECT_ID ... The fixed roles I was using don't give VIEW DATABASE STATE permission (which is ...


1

An owner of a database object has full rights on it automatically and unrevokably. But of course you can give an user all rights to a schema without making him the owner.


0

I do like the answer given on a similar question - http://dba.stackexchange.com/a/77683/11001 Obviously, I think the preferred DBA method to do this is simply to backup and restore to a different DB. But detach-copy-reattach is only one long file operation rather than 2 long file operations (backup, restore).


3

My answer doesn't answer your question directly, but addresses your method of operation. You shouldn't be logging in as postgres, just like you shouldn't be logging in as root on your servers. On your servers you should be logging in as real users and be using sudo for the odd occasion that you need superuser privileges. And preferably sudo su - ...


2

If you are connecting via psql -h 127.0.0.1 or psql -h localhost or just psql, it will determine HOW psql connects (either via TCP/IP or to a local socket, respectively). postgres' pg_hba.conf file may have an entry allowing to connect to TCP/IP (a line starting with host), but not to a socket (a line starting with local). Review your records in that file ...


4

this has nothing to do with databases. its how you os resolves the domain name in this case 'localhost' you /etc/hosts file should have an entry for localhost as below if you don't have it , then adding this entry will resolve your issue 127.0.0.1 localhost localhost.localdomain


0

Check your HOSTS file to see if you didn't screw it up (duplicate lines, wrong lines, etc). It should only have this in it: 127.0.0.1 localhost


8

You could create a domain group that you could use to create as login and user on your SQL Server and YourDatabase. After creating the domain group, you could do something like: USE [master] GO CREATE LOGIN [DOMAIN\AllUsersForYourDatabase] FROM WINDOWS GO USE [YourDatabase] GO CREATE USER [DOMAIN\AllUsersForYourDatabase] FOR LOGIN ...


-2

All the data used to be in default location of pc in fact wherever we are located doesn't matter so the default location is Ubuntu 9.10 Moving the database from /var/lib/mysql to /data/databases/mysql you can go and check your data there. It will be stored there and sometimes data may be hidden we can unlock it for seeing as a guest. If we are admin then we ...


3

Data is present in data folder of MySQL which is usually in ProgramData for windows installations. look into "C:\ProgramData\MySQL\MySQL Server 5.6"..as programdata usually have the files on by default


1

You're not seeing your databases in phpMyAdmin because you are logged in as the anonymous user. Log in using the new username and password you've created/changed to and you should see your old databases. By default, phpMyAdmin uses the "cookie" authentication mode, which means you're prompted when logging in. If you've changed that to be "config" you'll ...


0

Although openerp owns the database, the catalog tables are still owned by user postgres. In order to update pg_database, you need to be logged in as postgres, or another superuser role. This makes sense, given that pg_database contains entries not just for your database, but for every database on the server. If you want to disable connections to a database ...



Top 50 recent answers are included