New answers tagged

0

After further investigation, to specify the default initdb arguments used in pg_createcluster, the below was added in /etc/postgresql-common/createcluster.conf: initdb_options = '--data-checksums' Then pg_createcluster was run as normal and show data_checksums displays: data_checksums ---------------- on (1 row)


0

According the pg_createcluster usage message, initdb arguments have to go after a double dash. pg_createcluster --datadir=foo/cluster_name 9.3 cluster_name -- --data-checksums


0

When connecting to Mysql remotely, I got the error. I had this warning in /var/log/mysqld.log: [Warning] IP address 'X.X.X.X' could not be resolved: Temporary failure in name resolution I just added this line to /etc/hosts file: X.X.X.X some_name Problem solved! without using skip-name-resolve, it caused some errors in my local app, when connecting to ...


0

The expert @roaima says, "Because MySQL is a packaged application that stores its libraries in one of the "well known places".


0

We tried the same procedure on an Ubuntu workstation with MySQL 5.7.x on Ubuntu 16.04 and it worked without issue. Based on this, we decided to upgrade our server's OS to Ubuntu 16.04 which upgraded MySQL to v5.7.12. After changing my.cnf to reflect changes in some option names and restarting the service, the log files now have the correct sizes and the ...


1

Your connection string is wrong. With easy connect you need to provide a hostname and servicename/SID. In your case you would provide sqlplus user/"SomePass"@HOSTNAME:$PORT/servicename If you want to configure your connection in the tnsnames.ora, you can connect to it using sqlplus user/"SomePass"@TNSALIAS I actually don't understand the part of your ...


0

For databases dumped with pg_dumpall it is best to use pg_restore --create instead of psql.


0

pg_dumpall requires all tablespaces exist, otherwise database creation will fail for databases in non-default locations.


1

Looks like there are some hoops with fire you need to jump thru for installing Oracle XE on Ubuntu. You may want to try following the article here: http://meandmyubuntulinux.blogspot.com/2012/05/installing-oracle-11g-r2-express.html Oracle is very finicky when it comes to installing on particular OS's. It's very specific as to what they support. However, ...


2

Launch Shell as User: If all else fails, on Ubuntu 14.04 LTS running on AWS, try this... me@local $ ssh -i aws.pem ubuntu@foo ubuntu@foo $ sudo -u mongodb bash # OR whatever shell (zsh) mongodb@foo $ mongod --dbpath /data/db --fork OF COURSE, you'll add a much larger set of flags to the command. Note also that this assumes you're authenticated as ...



Top 50 recent answers are included