2 edited title and body
source | link

Replication log agent blocking distributor agent TLOG stuck Log Reader Agent Blocking Distributor Agent T-log Stuck with log_reuse_wait_desc replicationReplication

I've got a nasty sql serverSQL Server 2012 replication issue. I have a transactional publication going to a pull subscriber. The log reader agent on the publisher has gotten stuck in a loop of "Delivering replicated transactions, xcount: 1 with an increasing command count" messages

Delivering replicated transactions, xcount: 1 with an increasing command count messages

and "The replication agent has not logged a progress message in 10 minutes"

The replication agent has not logged a progress message in 10 minutes

messages. 

So the log reader agent seems to be working but nothing is being replicated to the distributors. All distributors state "The process is running and is waiting for a response"

The process is running and is waiting for a response

or they time outtimeout and try again. When I run sp_whoIsActivesp_whoisactive, I see the spid for the log reader agent for that database is blocking all the distribution agents from the subscribers of that database....yet the status of the log reader process is "sleeping"sleeping. The Tlogt-log for the publication database is growing fast and eating up storage. It's stuck with log_reuse_wait_desc replicationlog_reuse_wait_desc=REPLICATION, so I cannot shrink it. Anyone run into this before? Any suggestions on how to fix this? Appreciate the help. Thanks.

Replication log agent blocking distributor agent TLOG stuck with log_reuse_wait_desc replication

I've got a nasty sql server 2012 replication issue. I have a transactional publication going to a pull subscriber. The log reader agent on the publisher has gotten stuck in a loop of "Delivering replicated transactions, xcount: 1 with an increasing command count" messages and "The replication agent has not logged a progress message in 10 minutes" messages. So the log agent seems to be working but nothing is being replicated to the distributors. All distributors state "The process is running and is waiting for a response" or they time out and try again. When I run sp_whoIsActive I see the spid for the log reader agent for that database is blocking all the distribution agents from the subscribers of that database....yet the status of the log reader process is "sleeping" The Tlog for the publication database is growing fast and eating up storage. It's stuck with log_reuse_wait_desc replication, so I cannot shrink it. Anyone run into this before? Any suggestions on how to fix this? Appreciate the help. Thanks.

Log Reader Agent Blocking Distributor Agent T-log Stuck with log_reuse_wait_desc Replication

I've got a nasty SQL Server 2012 replication issue. I have a transactional publication going to a pull subscriber. The log reader agent on the publisher has gotten stuck in a loop of:

Delivering replicated transactions, xcount: 1 with an increasing command count messages

and

The replication agent has not logged a progress message in 10 minutes

messages. 

So the log reader agent seems to be working but nothing is being replicated to the distributors. All distributors state

The process is running and is waiting for a response

or they timeout and try again. When I run sp_whoisactive, I see the spid for the log reader agent for that database is blocking all the distribution agents from the subscribers of that database....yet the status of the log reader process is sleeping. The t-log for the publication database is growing fast and eating up storage. It's stuck with log_reuse_wait_desc=REPLICATION, so I cannot shrink it. Anyone run into this before? Any suggestions on how to fix this? Appreciate the help. Thanks.

1
source | link

Replication log agent blocking distributor agent TLOG stuck with log_reuse_wait_desc replication

I've got a nasty sql server 2012 replication issue. I have a transactional publication going to a pull subscriber. The log reader agent on the publisher has gotten stuck in a loop of "Delivering replicated transactions, xcount: 1 with an increasing command count" messages and "The replication agent has not logged a progress message in 10 minutes" messages. So the log agent seems to be working but nothing is being replicated to the distributors. All distributors state "The process is running and is waiting for a response" or they time out and try again. When I run sp_whoIsActive I see the spid for the log reader agent for that database is blocking all the distribution agents from the subscribers of that database....yet the status of the log reader process is "sleeping" The Tlog for the publication database is growing fast and eating up storage. It's stuck with log_reuse_wait_desc replication, so I cannot shrink it. Anyone run into this before? Any suggestions on how to fix this? Appreciate the help. Thanks.