2

I have installed full setup of SQL Server, and start the service for SQL Agent through SQL Server surface area. But still I can't get SQL Agent tree node in my SQL Server connection treeview.

So please help me what I have to do for getting SQL Agent in treeview.

  • 1
    Do you have the permissions to see it? SSMS lets me connect to the database see the tree; but unless the DBA granted me privileges, I couldn't see it either. – xQbert Jan 2 '12 at 14:29
1

Minimum rights needed to see the agent node you need to have sysadmin rights on the instance or rights to the agent database roles in msdb.

|improve this answer|||||
  • And an edition above Express – gbn Jan 3 '12 at 8:09
  • 1
    Thought about that, but he said he got the agent started, and the SQLEXPRESS agent instance defaults to disabled and doesn't start properly if you try to change the type. – Jason Cumberland Jan 3 '12 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy