Trying to create a backup device for a new db. I'm using management studio and just using the "New Backup Device..." wizard and giving UNC path to the backup directory.

There is a pre-existing db on another server, it has backups working to the same Samba share.

I'm setting up backups for a new db on a new node, same vlan/subnet using the same share, same domain account for the SQL service user.

I can access and read/write just browsing the UNC with Windows Explorer The share is presented as Samba from Gluster storage on RHEL.

Node1: Working node:

Service user: sqluser@domain.local, Path:\\shr01\main-storage\files\dbbackup\db1\full

Node2: Not working node:

Service user: sqluser@domain.local Path: \\shr01\main-storage\files\dbbackup\db2\full

Both directories have the same permissions and ownership, I've tried pointing the path from Node2 to the either share but I get the same result with either paths from Node2:


This means that the path can be found, but the permissions aren't working. The directory is owned by a sambaadmin@domain.local user from the file server and can be accessed by BOTH nodes in Windows with full read/write with the service user sqluser@domain.local, but it doesn't work via SQL Server backup device creation? Help. Please.


Figured it out -- Windows credential manager didn't have the credentials stored for the share. After adding the proper creds to the credential manager it worked ok.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.