1

I'm in the process of building the lab for 70-462 exam. On page 49 of the text, it provides the command to install SQL 2012 on Windows Server Core:

Setup.exe /qs /Action=install /Features=SQLEngine,IS,Conn
/InstanceName=MSSQLServer /SQLSYSADMINACCOUNTS="Contoso\kim_akers"
/IAcceptSQLServerLicenseTerms

When I run this code, it appears things are running fine, the GUI window comes up and shows progress, then all the sudden it quits, the GUI goes away, and then I'm left with the following at the CLI:

The following error occurred:
Object reference not set to an instance of an object.

Error restult: -2147467261
Result facitlity code: 0
Result error code: 16387

Please review the summary.txt log for further details

I've done some searching and haven't come up with much. Further, I don't know how to access this "summary.txt" file as it isn't anywhere to be found on the C:\ drive, so I can't see what file is stating.

Other details:

  • This is a lab built on top of Windows 8.1 (x64) using the Hyper-V feature.
  • 16 GB of RAM, with 2GB installed for each
  • Huge hard drive
  • 8-core CPU
  • The same ISO/DVD was used to install all the graphical versions of SQL server, so I don't think it is corrupt download
  • All OSes are x64 Windows Server 2008 R2
  • SQL Server 2012 x64 SP1 (I've also tried with SQL 2012 minus SP1)

If anything else is needed, let me know.

Edit #1 5-10-15 1:15pm CST

When I execute the dir command in the folder suggested by Shanky, I get:

  • (DIR) Datastore_ComponentUpdate
  • (DIR) Datastore_GlobalRules
  • (DIR) resources
  • (DIR) Watson_1
  • Detail_ComponentUpdate.txt
  • Detail_GlobalRules.txt
  • Registry_SOFTWARE_Microsoft_MSSQLServer.reg_
  • Settings.xml
  • Setting_GlobalRules.xml
  • SQL-CORE_20150510_091104_Watson_ComponentUpdate.txt
  • Summary_SQL-CORE_20150510_091104_ComponentUpdate.txt
  • Summary_SQL-CORE-20150510_091104_GlobalRles.txt
  • SystemConfigurationCheck_Report.htm
  • Forgot to mention, I've tried this from an ISO, DVD, and an uncompressed ISO from a folder on the desktop. – Sean Perkins May 10 '15 at 16:33
  • 1
    You can always add more information to your own questions by editing your own question. – Vérace May 10 '15 at 16:43
  • Can you please use link to locate summary.txt file and please add the content in question msdn.microsoft.com/en-us/library/ms143702%28v=sql.110%29.aspx You would find it at %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\. – Shanky May 10 '15 at 17:40
  • @Shanky - I've added a list of files to the location that you described, which file would you like to see? – Sean Perkins May 10 '15 at 18:17
  • Please upload all the files on Shared Location (Onedrive, Dropbox...) and post the link here so that we can access. – Shanky May 11 '15 at 4:11
1

I figured out the issue after doing some more searching and trial & error.

The process I used for finding the issue:

Started with the CLI and ran the following command:

This will provide a list of all features that are enabled and disabled

Dism /online /get-features /format:table

Next you use the following command to enable needed features

Dism /online /enable-feature /featurename:<featurename> 

Example:

Dism /online /enable-feature /featurename:MicrosoftWindowsPowerShell

ALL of the following features need to be enabled for the installation to be successful:

  • NetFx2-ServerCore
  • NetFx2-ServerCore-WOW64
  • NetFx3-ServerCore
  • NetFx3-ServerCore-WOW64
  • MicrosoftWindowsPowerShell
  • MicrosoftWindowsPowerShell-WOW64

When I posted this question, I had all, but “NetFx3-ServerCore-WOW64” enabled. Further, my problem was an assumption on my part. I assumed that these features would be installed along with SQL setup, this wasn’t the case from the CORE installation, you need to make sure these features are installed/enabled BEFORE the SQL 2012 installation begins. When I performed the GUI-based installations, I didn’t have worry about enabling the aforementioned features.

Moral of the story…DON’T ASSUME ANYTHING! ALWAYS check prerequisites if you’re having installation problems for any software/hardware.

  • well done. TY for posting the answer. – Ali Razeghi May 11 '15 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.