0

I am facing the following error when i try to restart the MySQL service after an unexpected shutdown of the database server last night.

Could not start the MySQL service on Local Computer.
Error 1067: The process terminated unexpectedly.

When i check the .err log file under MySql data folder, the log details are as per below.


InnoDB: Log scan progressed past the checkpoint lsn 804 2135184621 150513 12:20:39 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 804 2136195241 150513 12:20:50 InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 0 1 2 3 150513 12:20:50 InnoDB: Assertion failure in thread 2412 in file .\rem\rem0rec.c line 337
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http:// bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace.
150513 12:20:51 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary or one of the libraries it was linked against is corrupt, improperly built, or misconfigured. This error can also be caused by malfunctioning hardware. We will try our best to scrape up some info that will hopefully help diagnose the problem, but since we have already crashed, something is definitely wrong and this may fail.

key_buffer_size=135266304
read_buffer_size=65536
max_used_connections=0
max_threads=400
threads_connected=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 262617 K bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out where mysqld died. If you see no messages after this, something went terribly wrong...
InnoDB: Thread 164 stopped in file .\os\os0sync.c line 391
0070A1A8 mysqld.exe!rec_get_offsets_func()[rem0rec.c:337]
0071B498 mysqld.exe!page_cur_parse_insert_rec()[page0cur.c:798]
0071512F mysqld.exe!recv_parse_or_apply_log_rec_body()[log0recv.c:814]
00715CF1 mysqld.exe!recv_recover_page()[log0recv.c:1294]
006EBE0F mysqld.exe!buf_page_io_complete()[buf0buf.c:2033]
006E4472 mysqld.exe!fil_aio_wait()[fil0fil.c:4273]
006BCDCD mysqld.exe!io_handler_thread()[srv0start.c:437]
77E6482F kernel32.dll!GetModuleHandleA()


Error log show in Event Viewer:

An unhandled win32 exception occurred in mysqld.exe [1200]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.


MySQL version: 5.1
Table Type: InnoDB
ibdata1 Size: 28GB

There are no SQL dump backup files for the tables made and there is only the SQL physical data files. I am desperately needed to restore the data of these and bring the website back to online.

Please help.

0

Sounds like you have your data file corrupted. You may try to start up your server using innodb Force Recover and then dump your table data using Select Into Command. If you had your binary log file enabled before the crash, you may restore data through Point In Time Recovery

  • Thank you so much for your reply. I tried to force recover until level 4. But the same error message still persist. Should i proceed with level 5 and 6? Or is there any other settings which i need to check as well? – darrell May 13 '15 at 8:20
  • Apparently this is a known bug within MySQL 5.1 as mentioned within a few bug docs below. bugs.mysql.com/bug.php?id=44416<br> bugs.mysql.com/bug.php?id=45844 I have updated the MySQL version to the latest (5.1.73) and the force recovery the InnoDB at level 6 (can only be started at this level for my case). After that, i can proceed with mysqldump. – darrell May 18 '15 at 8:46
  • Just a heads up. some of you data may be missing after this process. – Masoud May 18 '15 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.