1

I met a problem from Oracle 12C Database, when I try to login to the user account with commandconn test/test, I got prompt of "invalid username/password, logon denied". invalid nsername/password when I use conn test/test@PDBORCL, I got "Could not resolve the connect identifier specified"Could not resolve identifier Can anyone please help me out? I really appreciate!!

2

Strangely, changing my service name to UPPERCASE has helped!

  1. Changed case of service name to UPPERCASE in tnsnames.ora for pluggable database ("ORCLPDB" in my case).

  2. Follow below commands:

    enter image description here

    Note: service name in uppercase while connecting ex SCOTT/TIGER@ORCLPDB

    Not sure why this has worked for me !!

| improve this answer | |
  • It's really strange, but when I create the user and password by using all caps, it works fine. But if I use lower case letters, I get the exact same issue – 130nk3r5 Jul 21 at 8:17
2

In the tnsnames.ora file, I added an entry for PDBORCL in which the SERVICE_NAME=pdborcl. Just changed it to uppercase like SERVICE_NAME=PDBORCL and the problem was solved.

| improve this answer | |
0

You can also connect directly with below syntax:

sqlplus TEST/test@localhost:1521/pdborcl

pdborcl is pluggable database name

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.