0

SQL SERVER EDITION- 2008 ENTERPRISE EVALUATION EDITION Operating System- Window Server 2008 R2

I've Created Local Smtp to use gmail id for Subscription of SSRS Report by Email as we don't have an Exchange Server.

Used this link to Create local SMTP for gmail

Below is the Screen Shot of rsreportserver.Config File enter image description here

ERROR : on Report Manager **ERROR : on Report Manager**

Below is report log on after time report was executed.

library!WindowsService_16!2b30!05/20/2015-13:19:05:: i INFO: Schedule 3374e590-8374-4360-b5da-d487eacb0417 executed at 05/20/2015 13:19:05. schedule!WindowsService_16!2b30!05/20/2015-13:19:05:: Creating Time based subscription notification for subscription: ea7fc6ce-00df-4f6a-9050-e713986307ca library!WindowsService_16!2b30!05/20/2015-13:19:05:: i INFO: Schedule 3374e590-8374-4360-b5da-d487eacb0417 execution completed at 05/20/2015 13:19:05. library!WindowsService_16!2b30!05/20/2015-13:19:06:: i INFO: RenderForNewSession('/Subscription') library!WindowsService_16!2b30!05/20/2015-13:19:06:: i INFO: Initializing EnableIntegratedSecurity to 'True' as specified in Server system properties. library!WindowsService_16!2b30!05/20/2015-13:19:06:: i INFO: Initializing SqlStreamingBufferSize to default value of '64640' Bytes because it was not specified in Server system properties. library!ReportServer_0-24!1f08!05/20/2015-13:19:08:: Call to GetPermissionsAction(/Subscription). library!ReportServer_0-24!2484!05/20/2015-13:19:08:: Call to GetSystemPropertiesAction(). library!ReportServer_0-24!1f08!05/20/2015-13:19:08:: Call to GetPropertiesAction(/Subscription, PathBased). library!ReportServer_0-24!1f08!05/20/2015-13:19:08:: Call to GetSystemPermissionsAction(). library!ReportServer_0-24!2484!05/20/2015-13:19:08:: Call to ListSubscriptionsAction(/Subscription, null). library!ReportServer_0-24!1f08!05/20/2015-13:19:08:: Call to GetPropertiesAction(/Subscription, PathBased). library!ReportServer_0-24!2484!05/20/2015-13:19:08:: Call to GetSystemPropertiesAction(). library!WindowsService_16!2b30!05/20/2015-13:19:10:: i INFO: Initializing SnapshotCompression to 'SQL' as specified in Server system properties. library!WindowsService_16!2b30!05/20/2015-13:19:11:: i INFO: Initializing ChunkSegmentSize to default value of '32320' Bytes because it was not specified in Server system properties. library!WindowsService_16!2b30!05/20/2015-13:19:11:: i INFO: Initializing ResponseBufferSizeKb to default value of '64' KB because it was not specified in Server system properties. library!WindowsService_16!2b30!05/20/2015-13:19:11:: Using folder D:\Program Files\Microsoft SQL Server\MSRS10.SQLSVR2008_NEW\Reporting Services\RSTempFiles for temporary files. library!WindowsService_16!2b30!05/20/2015-13:19:13:: i INFO: Initializing SessionTimeout to '600' second(s) as specified in Server system properties. library!WindowsService_16!2b30!05/20/2015-13:19:13:: i INFO: Initializing EnableExecutionLogging to 'True' as specified in Server system properties. library!WindowsService_16!37e0!05/20/2015-13:19:43:: i INFO: Call to CleanBatch() library!WindowsService_16!37e0!05/20/2015-13:19:43:: i INFO: Cleaned 0 batch records, 0 policies, 0 sessions, 0 cache entries, 0 snapshots, 0 chunks, 0 running jobs, 0 persisted streams, 0 segments, 0 segment mappings. library!WindowsService_16!37e0!05/20/2015-13:19:43:: i INFO: Call to CleanBatch() ends

Please Suggest if there's any requirement or step i'm left with.

PS: Local SMTP is working, i.e. i am able to receive email if i place an email.text file in C:\inetpub\mailroot\pickup

0

It was seriously LOL.

I gave NetworkService user full control to mailroot folder residing in C:\inetpub\ and Vola email was sent from localsmtp.

I bet if someone has faced this problem and has find any solution like same.

Reason OF Solution - login context/User that is rendering report on ReportServer and creating an email template to throw it in pickup directory residing in C:\inetpub\mailroot should be "Network Service"

Question/Doubt Left Now the confusion left is can we change this user as my service account user i.e. local Administrator was having full control on mailroot folder but it was not working till i opted above mentioned solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.