2

I'm trying to install Oracle client 12.1.0.2.0 (32-bit) on a completely clean copy of windows Server 2012, and I'm hitting a problem.

The installer runs fine until it gets to the final part - the net configuration assistant. An error message appears and says "[INS-20802] Oracle Net Configuration Assistant failed.". Here's the relevant part of the log file that is generated (I can post the entire thing if requested, but here's the bit with the actual error occurs):

INFO: Read: UnsatisfiedLinkError exception loading native library: oranjni12
INFO: Stderr Read: java.lang.UnsatisfiedLinkError: oracle.net.common.NetGetEnv.jniGetOracleHome()Ljava/lang/String;
WARNING: Skipping line: UnsatisfiedLinkError exception loading native library: oranjni12
INFO: Read: java.lang.UnsatisfiedLinkError: C:\app\ORACLE_USER\product\12.1.0\client_1\BIN\oranjni12.dll: Can't find dependent libraries
INFO: Stderr Read:  at oracle.net.common.NetGetEnv.jniGetOracleHome(Native Method)
INFO: Stderr Read:  at oracle.net.common.NetGetEnv.getOracleHome(Unknown Source)
INFO: Stderr Read:  at oracle.net.ca.NetCALogger.getOracleHome(NetCALogger.java:230)
INFO: Stderr Read:  at oracle.net.ca.NetCALogger.initOracleParameters(NetCALogger.java:215)
INFO: Stderr Read:  at oracle.net.ca.NetCALogger.initLogger(NetCALogger.java:130)
INFO: Stderr Read:  at oracle.net.ca.NetCA.main(NetCA.java:433)
WARNING: Skipping line: java.lang.UnsatisfiedLinkError: C:\app\ORACLE_USER\product\12.1.0\client_1\BIN\oranjni12.dll: Can't find dependent libraries
INFO: Read: 
WARNING: Skipping line: 
INFO: Read: Error: oracle.net.common.NetGetEnv.jniGetOracleHome()Ljava/lang/String;
WARNING: Skipping line: Error: oracle.net.common.NetGetEnv.jniGetOracleHome()Ljava/lang/String;
INFO: Read: Oracle Net Services configuration failed.  The exit code is 1
WARNING: Skipping line: Oracle Net Services configuration failed.  The exit code is 1
INFO: Completed Plugin named: Oracle Net Configuration Assistant

Here are a few things I have tried:

  • turning the firewall off
  • disconnecting from network (clutching at straws!)
  • running the installer as administrator
  • re-downloading the client installer from Oracle, in case it had somehow been corrupted

None of these things made any difference. I have successfully installed this exact version of the client on a Windows Server 2012 PC in the past and it worked fine...

Has anyone else encountered this issue?

3

The install/oraparam.ini contains the following lines (even in a fresh download):

#MSVCREDIST_LOC flag will provide the name of the exe that is being shipped in stage/ext/bin  
MSVCREDIST_LOC=vcredist_x64.exe

This is incorrect because you need the 32-bit version (x86).

Now if you check stage/ext/bin, there is a file vcredist_x86.exe, and obviously no x64, since it is a 32-bit installer. Try editing oraparam.init and fixing the above line to:

MSVCREDIST_LOC=vcredist_x86.exe

Another possibility is that you need to install the Microsoft C++ 2010 Redistributable manually: http://www.microsoft.com/en-us/download/confirmation.aspx?id=5555

  • You were correct! I didn't have to change the oraparam.init file though. I just installed MSV_REDIST manually before the install. When I did this before I had (by chance) installed the MSV_REDIST as part of another bit of software before Oracle. – user1578653 May 21 '15 at 16:04
0

In case someone will get this error on windows 7 that has oracle express installed- uninstalling express solved the issue for me.

0

When installing Oracle Client (any version), we prep the server by installing IIS with .NET Framework 3.5 and 4.0 features. The Oracle Net Config Assist seems to fail without .NET Framework 3.5. I believe C++ 2010 Redistribution is included in 3.5. Also for 12, 32 bit, we needed to fix install/oraparam.ini like the previous person said.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.