1

I had a SQL Server 2008 Express edition as a Default instance and I am having SQL Server 2012 Evolution and SQL Server 2014 Evolution are my named instances. When I was trying to configure Replication on my SQL Server 2014 as a Distributor as well as Publisher, I am getting the following error:

'NITHYAN\DBA2014' cannot be configured for publishing and distribution. Publishing and distribution are supported only in SQL Server version 7.0 or later.

If I am trying to configure on SQL Server 2012 as Distributor as well as Publisher it allow me to do Replication.

I don't understood what's wrong with SQL Server 2014. Why do I get the above error?

  • On SQL 2014, how is Publisher and Dist configured? – KASQLDBA May 21 '15 at 11:58
2

Downlevel versions of SSMS cannot always connect to uplevel versions of SQL. When configuring replication, please ensure you are using the version of SSMS from your Distributor. In your case, based on the error message, you are using the SSMS from the Express version of SQL. Instead, use the version from your Distributor instance.

0

If you have SQL 2008R2,2012,2014 If you open 2012,2014 instance in 2008 R2 Management Studio you will get the above error if you want to avoid this error open management studio @ 2014 all will work fine.....

Hope so this may help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.