10

I receive this error message in SQL Server error log every 15 minutes. I have setup AOAG on this server. The database option "Service Broker - Broker Enabled" is turned on for the Blackberry related databases and MSDB databases on this instance. Blackberry support mentioned they do not need this enabled. I have other AOAG instance and they do not receive this error.

Please share your wisdom in this regard. I have not used service broker yet and did not find a similar post on stack exchange from my search.

Thank you

1
  • What patch (version) is sql server 2012 running on ? Seems like you would need latest SP/CU. Check this answer.
    – Kin Shah
    May 28, 2015 at 14:54

3 Answers 3

4

According to this link,

It’s a default behavior. The message will show when AlwaysOn availability group Listener is created and SQL Server binds the Listener’s IP dynamically. There is no method to suppress the message. These messages are informational message and do not cause any harm and can safely be ignored.

That link also gives a query to see which databases do and do not have brokers enabled:

SELECT is_broker_enabled, name  FROM sys.databases  
1

I created a service broker endpoint in a test environment out of curiosity where these messages were occurring and this resolved the issue.

CREATE ENDPOINT BrokerEndpointTest
STATE = STARTED
AS TCP (  LISTENER_PORT = 4022  )
FOR SERVICE_BROKER (AUTHENTICATION = WINDOWS  );
GO
-5

Please ensure [NT AUTHORITY\SYSTEM] is a sysadmin on all nodes of the availability group.

ALTER SERVER ROLE [sysadmin] ADD MEMBER [NT AUTHORITY\SYSTEM];
GO
1
  • 3
    You should add details about why this is required.
    – Hannah Vernon
    Jan 4, 2017 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.