1

I have created a package that brings in data from another database and with the data package populates a table in SQL database. The job runs fine when it is executed. I've imported it into SQL and it still works fine. But when I try to automate it using SQL Job agent, I get the error that Requested registry access is not allowed, and in the log says:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {485F9D22-B7A7-446B-BBCB-23706B2624E3} and APPID {83B33982-693D-4824-B42E-7196AE61BB05}

I'm using SQL management studio 2012.

5
  • 2
    Get your dbas to give the correct permissions to the account that SQL Server agent uses.
    – HLGEM
    May 28, 2015 at 19:27
  • Thanks, I tried that, I added the user I log into SSIS with to the database as a dbo and I still get the same error.
    – Michael Kohler
    May 28, 2015 at 20:03
  • 1
    The error message sounds like the SQL Agent account doesn't have permission to execute SSIS packages. Clearly it's some form of permissions issue, and I would have a DBA look at it.
    – Tab Alleman
    May 28, 2015 at 20:04
  • Have you tried these troubleshooting steps? support.microsoft.com/en-us/kb/918760
    – Tom V
    May 29, 2015 at 9:10
  • you have to go to component services and give the SQL Agent service account permissions to activate the package. I don't remember exactly but you have to find Dts something there (depends on version of SQL Server). Also you can look up the name of the application using the GUIDs from the error msg.
    – BuahahaXD
    May 29, 2015 at 10:09

1 Answer 1

3

There is a step-by-step instructions on how another person had fixed it via this link. Essentially, the set-up best practices weren't followed when setting up the SSIS service and their DBA/admin used the network service. This caused some permissions not to grant properly during set-up.

1
  • That's a great article because it gets into the guts of things. But a much simpler solution is to give the SQL Agent service an appropriate account, rather than give the incorrect SQL Agent account sufficient DCOM access
    – Nick.Mc
    May 29, 2015 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.