I have a SQL Server Agent Job. The 'Include step output in history' checkbox is unchecked. However, when I right-click oon the job and select 'View History', I can see that it is tracking step output.

There is just the one step on the job.

Why is this? Am I missing some setting?

enter image description here

enter image description here

1 Answer 1


That check box does not prevent job step history from being recorded/stored. SQL Server is going to do all this by default and that I know of you cannot turn it off.

The check box referenced is for telling SQL Agent to store additional or more detailed job step output. It would store this information to msdb.dbo.sysjobstepslogs. Which from my testing just checking that box alone does not do anything. You would still find the table empty if you queried it. Once I also checked Log to table, ran the job again, and then it showed a record for the job step.

This would enabled on a job that runs DBCC CHECKFILEGROUP command for a database: enter image description here

  • 1
    Step output in this case means all standard output from processes called in the job step - Output from for example: queries, powershell scripts; executables. The job history table will always include time, error and limited output the include step output option starts verbose loggin: mssqltips.com/sqlservertip/1411/…
    – Spörri
    Jun 12, 2015 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.