1

I've set up a transactional replication for two databases, let's call them A & B.

Replication for the database A worked just fine and I was able to delete it afterwards without any issues.

Replication for the database B would error out and after checking the logs I found (Could not obtain information about Windows NT group/user 'DOMAIN\someaccount', error code 0x5.).

I was going to start fresh but now I am not even able to delete it. I am trying to remove a publication from the Publisher/Distributor (both using code and via Management Studio) and getting the same error.

What concerns me is database A had no issues whatsoever, and also the fact that DOMAIN\someaccount does not appear to own any objects or be referenced within the database at all.

Please help!

  • @Stan, Error 0x5 means access denied.Have you check out privilege for that DB. – Md Haidar Ali Khan Jun 16 '15 at 6:35
  • What is DOMAIN\someaccount? Is it the service account? Does it exist in AD? I've only ever seen this once and it was down to an issue with AD. – David Fowler Jun 6 '17 at 13:16
1

Looks like you have an object owned by a user that the service account can't validate. you can figure out what object it is, and change the owner of the object to sa. If it's the database, run this:

exec sp_changedbowner 'sa'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy