i'm using redhat 6, installed of oracle and created a database.

database (dev12ee1) is a non-container database, there is also an 11g database on the server (dev11ee1)

lsnrctl status shows standard port of 1521 and 5500

lsnrctl status

LSNRCTL for Linux: Version - Production on 17-JUN-2015 11:46:54

Copyright (c) 1991, 2014, Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version - Production
Start Date                02-JUN-2015 12:28:48
Uptime                    14 days 23 hr. 18 min. 6 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Log File         /u01/app12/oracle12/diag/tnslsnr/csya-oradev5/listener/alert/log.xml
Listening Endpoints Summary...
Services Summary...
Service "dev11ee1.csya-oradev5" has 1 instance(s).
  Instance "dev11ee1", status READY, has 1 handler(s) for this service...
Service "dev12ee1.csya-oradev5" has 1 instance(s).
  Instance "dev12ee1", status READY, has 1 handler(s) for this service...
The command completed successfully

the port settings in sqlplus look like this

SQL> select dbms_xdb_config.gethttpsport() from dual;



the local_listener and dispatchers database parameters are both blank (which should be ok as everything is standard and default).

but when i go to the URL


i get "This webpage is not available"

  • For reference, I think this question addresses the same issue (not answered yet): dba.stackexchange.com/questions/104130/…
    – Wouter
    Sep 29, 2015 at 11:47
  • Also this question, is the same: dba.stackexchange.com/questions/46551/…
    – Wouter
    Sep 29, 2015 at 11:52
  • Does your server have multiple network adaptors? Check listener.log at the time you try to connect to the webpage. Does it contain a TNS-12518 error? Is the IP address mentioned in this error the same as the IP address your hostname maps to? Or is it the IP address of one of the other adaptors? Is the problem solved if you disable the other adaptors?
    – Wouter
    Dec 18, 2015 at 14:18

2 Answers 2


Try browsing to

For me this works, but everything is -very- -very- slow (a few minutes just to load the login page).

I'm suspecting the slowness has something to do with the certificate. Why the IP-address works and the hostname doesn't... probably some configuration issue.

At least now anyone with more experience has something to go on...

For reference, all these posts seem to be about the same issue to me, but so far none has been answered:


I had the exact issue on RH7.3 with Oracle While the alert.log was clean, on the listener log there would be messages like the following ones when trying to connect on the em console:

<msg time='2018-09-24T13:15:41.816+03:00' org_id='oracle' comp_id='tnslsnr'
 type='UNKNOWN' level='16' host_id='database.comp.local'
 host_addr='' pid='2380'>
 <txt>TNS-12518: TNS:listener could not hand off client connection
 TNS-12560: TNS:protocol adapter error

It turned out the xdb_wallet directory had the wrong permissions:

[oracle@dbserver admin]$ ll /apps/oracle/admin/database/xdb_wallet
ls: cannot access /apps/oracle/admin/database/xdb_wallet/ewallet.p12: Permission denied
ls: cannot access /apps/oracle/admin/database/xdb_wallet/cwallet.sso: Permission denied
total 0
-????????? ? ? ? ?            ? cwallet.sso
-????????? ? ? ? ?            ? ewallet.p12

Changing the permissions on the xdb_wallet (and the files beneath it) solved the problem:

[root@dbserver ~]# cd /apps/oracle/admin/database

[root@dbserver database]# chmod 755 xdb_wallet

[root@dbserver database]# su -l oracle

[oracle@dbserver ~]$ cd /apps/oracle/admin/database
[oracle@dbserver database]$ ll
total 0
drwxr-x---. 2 oracle oinstall 20 Feb 15  2018 dpdump
drwxr-x---. 2 oracle oinstall 36 Feb 15  2018 pfile
drwxr-xr-x. 2 oracle oinstall 44 Feb 15  2018 xdb_wallet

Now it started working. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.