Our web server uses SQL Server 2008 R2. I have one development machine that connects to it with the IP address through SSMS and when testing my aspx website. I have several other machines though that can't connect to the IP through SSMS. I'm getting this error:

A Network-related or instance-specific error occurred while establishing a connection to SQL Server.
The server was not found or was not accessible. Verify the instance name is correct and the SQL Server is configured to allow remote connection.
(provider: Named Pipes provider:40-could not open a connection to SQL Server) (Microsoft SQL Server, Error:53)

I've got TCP/IP enabled, port 1433 open, all of that. Remember that I can connect from one development machine, but not others.

  • check connection properties in the connect to server dialog box in SSMS to make sure the network protocol is set to TCP/IP on machines that cant connect. you could also just try TCP:servername in your connection string. – Bob Klimes Jun 17 '15 at 14:22
  • Can you ping the servers from these other dev machines? – Vérace Jun 17 '15 at 15:14
  • Interestingly enough, ping does not respond from the machine that works or the ones that don't. – David Kroll Jun 17 '15 at 15:19
up vote 4 down vote accepted

Here are some of the things from my connection issue checklist

  • Check for an alias on the machine that can't connect
  • Check for firewall rules
  • Check and make sure the SQL Server drivers on the machines that don't work are up to date.
  • Try connecting with servername:port rather than just servername
  • Try pinging the SQL Server IP address from the machines that can't connect.
  • Can you elaborate on checking for an alias? – David Kroll Jun 17 '15 at 14:57
  • Run cliconfg.exe and look at the alias tab. You can also look at the general tab and try enabling TCP/IP (if it isn't already) – Kenneth Fisher Jun 17 '15 at 15:29
  • There were no aliases on the client or server. I enabled TCP/IP and Named Pipes on client and server, still can't connect. – David Kroll Jun 17 '15 at 15:39
  • Can you ping the DB server from that machine? Also you could try opening up an UNC path in windows explorer and see if that can see it. – Kenneth Fisher Jun 17 '15 at 16:30
  • Neither of those work. I can't even ping from the machine that can access the db server. – David Kroll Jun 17 '15 at 17:24

Turns out that our GoDaddy dedicated server had a Cisco hardware firewall that had one IP permitted for TCP port 1433. My VM was on the network that had that IP, while my other machine was not. After spending several hours trying to get the Cisco ASDM software to launch properly, I was able to add the IP address of my other machine and it's now working. Thank you all for your replies!

Could you try :

  • Named Pipes instead of TCP in SSMS connection properties
  • SQL authentication (create a SQL login if needed) instead of Windows

See also this link on the Microsoft developer website

I tried all the above answers without success, and eventually discovered the error was happening because no security protocols were enabled on the host machine (SSL 2.0, SSL 3.0 & TLS 1.0). Strangely, I could still still connect from some machines but not others.

You'll need to update some registry entries and restart the machine, as described in the link

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.