3

I have two instances (ORA1 and ORA2) of Oracle 11g at the same machine. One is starting the other cannot startup anymore.

What happend:

First my disk was full, so I accidentally deleted all ora*-files under /dev/shm. After deleting other files I had enough disk space to start instance ORA2. But when I tried to start ORA1, I get ORA-00845: MEMORY_TARGET not supported on this system

I cannot even start ORA1 in nomount phase: SQL> startup nomount; ORA-00845: MEMORY_TARGET not supported on this system

ORA1 and ORA2 should be configurated equally. /dev/shm has 2G and following parameter are set in ORA2:

SQL> show parameter target

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
archive_lag_target                   integer     0
db_flashback_retention_target        integer     1440
fast_start_io_target                 integer     0
fast_start_mttr_target               integer     0
memory_max_target                    big integer 0
memory_target                        big integer 0
parallel_servers_target              integer     32
pga_aggregate_target                 big integer 382M
sga_target                           big integer 1152M

What needs to be done? Any hints or explanation appreciated.

Thanks in advance!

  • The /dev/shm mount point should have twice as much space to allow both instances to run concurrently. – Marco Baldelli Jun 12 '15 at 14:11
  • Hope you have a backup? – OldProgrammer Jun 12 '15 at 15:27
  • @MarcoBaldelli Which value do you mean? sga_target? – Franz Jun 14 '15 at 18:35
  • @OldProgrammer Nop I probably haven't a backup, since it is just a testing environment - are these files really necessary to startup Oracle? As much as I know about these files they are just temporary Working Memory files, aren't they? – Franz Jun 14 '15 at 18:38
3

As described in https://www.krenger.ch/blog/ora-00845-memory_target-not-supported-on-this-system/ and suggestion of MarcoBaldelli /dev/shm just needs to have enough space. So the solution was to increase /dev/shm:

mount -o remount,size=4G /dev/shm

When MEMORY_TARGET is set to 0 (as in my case) it seems to be as following (see Oracle Documentation):

For the MEMORY_MAX_TARGET initialization parameter, decide on a maximum amount of memory that you would want to allocate to the database for the foreseeable future. That is, determine the maximum value for the sum of the SGA and instance PGA sizes. This number can be larger than or the same as the MEMORY_TARGET value that you chose in the previous step.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy