0

I am using Talend to backup MS SQL to MySQL Server. Everything goes well, I have a connection, data flows from one db to the other... however I cannot correctly copy diacritic signs.

On MS SQL I have Polish_CI_AS and on MySQL I have Latin2 general_ci.

When I tried to copy data from MS SQL to an Excel file, everything is in place. I concluded that problem lies in MySQL.

Have you encountered this issue before?

  • you have to use the same character set everywhere, including the client->db connection. just because your table/field collation is 'X' doesn't mean the client->db will be using 'X' as well. – Marc B Jun 24 '15 at 14:43
  • I can't find the same POLISH_CI_AS collation in MYSQL. Thus I used Latin2 general_ci which provides the same functionality (correct me if I am wrong). There must be a clever way of fixing it... – Mike Gorski Jun 24 '15 at 14:54
0

In Talend MysqlOutput -> Component window -> Advanced settings. Add the following:

"useUnicode=true&characterEncoding=latin2"
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.