0

I have a website hosted on GoDaddy and I need to create a database for it.

I headed to the Databases section and created a SQL Server Database, then on my local pc I tried to access the database via SQL Server Management Studio. I was able to login to the database but I cannot make any operations. I get a message saying "it does not exist or you do not have permission".

I decided to go to the Security tab, then Login and tried to change my username that I'm using to systemadmin role but received:

Cannot alter the server role 'sysadmin', because it does not exist or you do not have permission.

What could be the problem? There are no other accounts on it. The default sa account is disabled and I can't enable it because it will prompt no permissions etc.

I don't understand it. Why does GoDaddy allow me to create a database but with no permissions or rather I cannot alter it?

1
  • 2
    I'd suggest this is a question for your service provider directly. Commented Jun 29, 2015 at 9:40

1 Answer 1

1

You can't use sysadmin (sa) if you register shared hosting. You need to create your database via their control panel, then you can manage your database via your CP. Or some providers allow to connect remotely. For more information, just contact your hosting provider. Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.