6

I've been using Postgres and pgAdmin III for some years, but this morning I had a very BIG BIG problem. I'm using pgAdmin III 9.0 on Windows Xp operating system, on my laptop Dell Latitude E4300.

From this morning, Query Builder ("SQL Editor") option simply stopped working. When I open pgAdmin, everything is fine and workin', until I click on the Sql Query Builder button. When I do that, nothing appears and pgAdmin crashes without giving any information.

I tried to uninstall and install PgAdmin III 9.1, again, but Sql Query Builder kept not workin'.

What could I do?

2
  • For clarification: @Daves confuses pgAdmin (the GUI, latest version 1.14.1) with PostgreSQL (the database management system, latest version 9.1). The problem is (was) with pgAdmin. Feb 17, 2012 at 18:36
  • Sorry my bad English. I am Brazilian. The setup worked. I'm using pgAdmin III 9.0 on Windows 7 operating system. I rename the files C:\Users\"myuser"\AppData\Roaming\postgresql C:\Users\Administrador\AppData\Roaming\postgresql to: C:\Users\"myuser"\AppData\Roaming\postgresql\pgadmin_histoqueries_old.xml C:\Users\Administrador\AppData\Roaming\postgresq\pgadmin_histoqueries_old.xml Thank you so much.
    – user25607
    Jul 3, 2013 at 13:53

1 Answer 1

14
+50

We had the same problem 2 times on two different computer, in just a few days of interval.

PgAdmin started to crash each time we open query builder.

Restarting the computer, reinstalling pgAdmin with differents versions... Nothing resolved the problem. But we found the solution to this problem!

PgAdmin uses a file where it saves the last queries (kind of history) and this file was probably corrupted (or one of the queries was).

This file is in the Application Data of your Windows User, that's why reinstalling pgAdmin doesn't work: this corrupted file is common for every postgres install.

So you just got to rename or delete the file pgadmin_histoqueries.xml located in your AppData (for us, D:\Documents and Settings\XXXXX\Application Data\postgresql) and relaunch pgAdmin, this should be OK.

5
  • 2
    You just save me from a lot of headache. I started a bounty to award some extra credit. Feb 15, 2012 at 17:51
  • 1
    I did the following and i solved the issue for me. Try the menu "View/Default View" so that if fixes each component's location. From postgresql.nabble.com/… Sep 29, 2015 at 17:51
  • Jorge - lifesaver, I had a non-drawing weirdly non-responsive query window, it started after I remote desktopped into my machine. It's normally a High DPI 4k display set at 150% scaling but over RDS was not. Clearly something got messed up, and View / Default View fixed it up nicely. Feb 11, 2016 at 17:25
  • Anyone know the location on Mac?
    – Douglas
    Aug 12, 2019 at 22:03
  • If you are on a different configuration, you can get around the issue by creating a new server on the same server group and accessing the database from there. This isn't really a fix, but it does work just fine. Hope that helps someone!!
    – Douglas
    Aug 14, 2019 at 20:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.