0

My disk drive was full. So I deleted some records. Then I tried to shrink and it indicated available free space of around 5GB as indicated in the below image.

enter image description here

Once I ran the shrink for data file, though it completed successfully I didn't get the 5GB space as indicated. Infact the disk size remained the same. Nothing was shrunk. For log file shrink it shows available space of 200MB and when I run a log file shrink it does free up 200MB as indicated. So why is it not working with data file shrink? What am I doing wrong? Please advice.

2

In shrink action, you need to choose:

"Reorganize pages before releasing unused space"

And choose desidered size.

Actually you don't have released space because you have still used pages ad the end of your file.

Edit:
You can do it via query, with instructions like this:

DBCC SHRINKFILE (N'MATRIX24X7' , 449000)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.