I am installing mysql-5.5.7rc from source code. After installation when i start mysqld service is being run but as soon as i run mysql client service server service gets aborted.. And also mysql_install_db is not being installed even after running mysqld service running.

Please someone help me..

closed as off topic by jcolebrand Jan 13 '12 at 15:25

Questions on Database Administrators Stack Exchange are expected to relate to database administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

migrated from stackoverflow.com Jan 13 '12 at 9:37

This question came from our site for professional and enthusiast programmers.

  • Can you please write more Information? Operating system? Have you checked the syslogs? – René Höhle Jan 13 '12 at 8:32
  • belongs on serverfault.com – Mchl Jan 13 '12 at 8:37
  • OS-ubuntu 10.10... Started mysqld service by ./mysqld --skip-grant (location /usr/local/mysql/bin)...Now when i run ./mysql then mysqld service gets aborted... – Dipankar Saha Jan 13 '12 at 8:44
  • Unfortunately this question was too vague in it's original form. It should really have been asked on another site, perhaps Ask Ubuntu but it needs a lot more detail if it will get asked again. Therefore, this question is closed as Off Topic. – jcolebrand Jan 13 '12 at 15:25
  • MySQL 5.5.8 is the first GA release of MySQL 5.5. I would not trust anything before MySQL 5.5.8. Upgrade to the latest, please. – RolandoMySQLDBA Jan 13 '12 at 16:39

First of all try to stop the mysql server by mysqld stop and then try to start the service.

or user super user authentication to like su command before your command and if password ask enter your ubuntu login password