1

I moved servers. I exported DB on old, imported to new. Kept getting syntax error on import until I tried no compression. Weird, but it worked. I was skeptical so I compared the two carefully and noticed total file size was 51.7 megs (new) vs 51.4 (old). Looks more carefully and noticed at the bottom under "type" it shows myisam (new) where it was innodb (old). In both cases, each and every table is listed as innodb.

If I'm looking at a problem here, I'd rather know now than later. Thanks.

ps. I noticed during SQL errors that it was referencing mariadb (never heard of that before) where old would always say "mysql". Checked versions of both. Old was NEWER 5.6 while new server is 5.5. Is that a problem?

  • InnoDB and MyISAM are TABLE engines, database cannot be any of them. Do you mean default engine? Thats global/sesson variable, again not a database dependent one afaik. Can you paste at least part of the output and maybe some error message you got? – jkavalik Jul 16 '15 at 11:09
  • I may mean default engine, I don't know. It certainly doesn't say that. It is a emboldened row listed beneath all the tables in phpmyadmin as a summary (totals of tables sizes, for example) and clearly states myisam whereas all tables say innodb. The error message I got the first times (attempting while database was compressed) were syntax errors. No errors when importing uncompressed. Here's a screenshot: pasteboard.co/20pfDpNr.jpg – bcsteeve Jul 16 '15 at 17:06
  • If phpmyadmin shows default engine, then it depends on server config. It does not change anything about your tables as they are explicitly InnoDB. The syntax errors might be 5.6 stuff not being compatible with 5.5 – jkavalik Jul 16 '15 at 19:47
  • Ok, doesn't sound like I have a problem then. Again, the syntax errors ONLY happened when importing with a compressed file (file.sql.gz) when using uncompressed (file.sq) it worked fine (took forever, but it worked) – bcsteeve Jul 16 '15 at 20:48
  • Ah, you mean using .gz directly? yep that would error fast, mysql does not ungzip it by itself. Yep, big dump can take a lot of time to import and much longer if server is not configured for fast imports, but overall you are OK. – jkavalik Jul 17 '15 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.