8

In SQL Developer, from the top menu choose Tools > Data Export. This launches the Data Export wizard. enter image description here

So that is export. It creatres export.sql file. Now how to do import ? I am usgin SqlDeveloper 3.20.

Trygin to follow this tutorial , and have created new connection but I cannot find import. Tools->Preferences->Database->Utilities->Import Method and than what ?? I have tried to run script @C:\locationOfExportFile\export.sql

And I am getting eroors

SQL Error: ORA-00942: table or view does not exist 00942. 00000 - "table or view does not exist" *Cause:
*Action:

BTW, I have no idea what am I doing i just want to get that database to localhost. Other computer and my computer both have Oracle 11g Express database. Schema name is the same!

  • It is in tools - preferences. – tesla747 Jul 18 '15 at 14:25
  • yes I can see under Tools->Preferences->Database->Utilities->Import Method and than what ?? run script @C:\locationOfExportFile\\export.sql What elese should I do? – malakrsnaslava Jul 18 '15 at 21:53
  • Looks like one of the objects did not make it. Try with "dependents" enabled in the export DDL options. – Emacs User Jul 19 '15 at 1:17
2

Open the file(s) it has created, and run them with F5 in SQL Developer. They should also work in SQL*Plus.

They'll create the tables/objects (if you have the Export DDL option checked), and then they'll INSERT the rows (if you have the Export Data option checked.)

Note that there are more efficient ways for moving objects/data around, especially when dealing with very large amounts of data - namely, Data Pump.

This particular feature is very helpful when wanting to do ad hoc data and object exports - especially when you, the developer, don't have access to run Data Pump.

0

I had the same problem. When executing the file "export.sql" it indicated me the error "table or view does not exist".

I noticed that the insert / create were in this way "CREATE TABLE 'XXXXX'. 'TABLE1'", where 'XXXXX' was a schema that had not been created.

So I created a user with the name 'XXXXX' and the necessary GRANT. I created a new connection with that user in the sql developer, I executed the script again and it worked without problems.

I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.