3

I have tried using the system preferences and then shutting down MySQL there, but to no avail. I also tried typing killall -9 and -11. Both failed :(.

I also tried /usr/local/mysql/bin/mysqladmin -u root -p shutdown. The last thing I tried is in the following screenshot... it also did not work.

enter image description here

I am using yosemite, if that matters.

3

Ideally you can shutdown using

/etc/init.d/mysqld stop 

I cannot add comments so requesting to post what do you see in error log when you do

mysqladmin shutdown 

About kill commands please note that mysqld_safe is wrapper script which will start mysqld upon killing... so you should kill mysqld_safe first followed by mysqld. ( not a suggested way though).

Refer: how to stop mysql on mac

  • typing '/etc/init.d/mysqld stop' yields No such file or directory – user26658 Jul 22 '15 at 6:11
  • typing 'mysqladmin shutdown' yields shutdown failed; error: 'Access denied; you need (at least one of) the SHUTDOWN privilege(s) for this operation' – user26658 Jul 22 '15 at 6:13
  • Use root user... mysqladmin -uroot -p shutdown – mysql_user Jul 22 '15 at 6:16
  • that command works with no errors. However, when I check ' ps -Af | grep mysql', I still have processes running. Additionally, in my system preferences, the MySQL Server Status is still running. When I click Stop MySQL server, it stops, but then runs moments later. Thanks so much for helping me thusfar! – user26658 Jul 22 '15 at 6:25
  • Post what do you see in error log!! – mysql_user Jul 22 '15 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.