1

My SSIS package is running fine in BIDS but when I tried to schedule the job it's showing:

Argument "ORARACOCCUAT1.xxxxxxx.COM" for option "connection" is not valid.
The command line parameters are invalid.
The step failed.

I'm trying to move data from SQL Server to Oracle. I'm executing the package as well as scheduling the job in same server.

My command line is:

/FILE "C:\Users\..(snip)..\VERIFIERTERMCODE.dtsx"
/CONNECTION "10.226.211.222.KK.*";"Data Source=10.226.211.222;
User ID=*;Initial Catalog=KK;Provider=SQLNCLI10.1;
Application Name=SSIS-VERIFIERTERMCODE-{6B1F6F56-1097-4F40-B681-217B3EB954C1}
10.226.211.222.KK.*;Auto Translate=False;\"" 
/CONNECTION "ORARACOCCUAT1.xxxxxxx.COM/LSSUATDB.*****";
"\"Data Source=ORARACOCCUAT1.xxxxxxx.COM/LSSUATDB;
User ID=*****;Password=****;Provider=OraOLEDB.Oracle.1;\"" /X86
/CHECKPOINTING OFF /REPORTING E

Steps I tried to fix this issue:

  1. As stated on this site:

    If your SQL Server is 64 bit
    In SQL Server JOB-->Properties-->Steps--->
    In the Execution Option Tab -- Check "Use 32 bit runtime"
    In the Data Sources Tab -- Uncheck the checkboxes of the connection managers if checked.
    Schedule the Job and run it.

...but that is not working for me and showing the same error.

  1. As mentioned on this site, removed hyphen and double quotes before Data source and after Provider but getting same error.

Can anyone help me to fix this?

1 Answer 1

1

I fixed this issue by changing the connection name(without space, dot,comma) of both source and destination in Package itself and I tried to run the job manually by clicking Start Job at Step and it worked fine :)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.