I'm using the Oracle ODBC Driver 11.2 to access an 11.2 Oracle Database. It seems that the driver does not return tables nor columns remarks (comments) when calling the SQLTables() or SQLColumns ODBC API.

Is there some flag in the registry or wherever to define in order to get this information with the Oracle ODBC Driver for tables and columns, ou should I use custom queries instead of using SQLTables + SQLColumns() to read the catalog?

I googled this for a while now, and it seems that there's no such flag, at least for the Oracle ODBC Driver I downloaded from Oracle, but an undocumented parameter might exist, or may be I just did not find it.

  • I don't know about ODBC, but the JDBC driver needs to be explicitly told to return column remarks (using a connection property named remarksReporting)
    – user1822
    Jul 21, 2015 at 8:41
  • ok, thanks. unfortunately I don't find something close to this option for ODBC (JDBC is not an option at this time...)
    – ggo
    Jul 21, 2015 at 12:29
  • Which platform are you on? Jul 21, 2015 at 12:56
  • to down-voters: please explain why when you down-vote. Thank you.
    – ggo
    Dec 26, 2019 at 16:04

1 Answer 1


http://docs.oracle.com/cd/E19531-01/817-2514-10/GlossaryContext11.html indicates that setting CatalogOptions will cause the column remarks to be populated when executing SQLTables or SQLColumns.

  • Do you know if this option is an option of the Oracle ODBC driver (the one from Oracle) which can be defined in the Oracle ODBC driver configuration (in the registry)? According to what I have read in another page of the Sun ONE Active Server Page documentation you mentioned, it seems that they talk about the DataDirect Connect ODBC drivers (not the driver from Oracle) docs.oracle.com/cd/E19531-01/817-2514-10/Ch1_Introduction6.html
    – ggo
    Jul 21, 2015 at 12:44
  • I think you might be right, unfortunately. Jul 21, 2015 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.