2

Trying to install Oracle DB 11g EE on RHEL 7. Installed the necessary packages as mentioned in the below link (Section 6.1).

But I am stuck at the package check step, which fails because it couldn't find earlier versions of the packages.

Ex of one of the package error:

![Error Snippet of one particular package]

  • Expected Value: libaio-0.3.105 (i386)

Also, when I try to install the required package, the repo doesn't find those versions. If I ignore, I am getting the below error.

![Snippet: Stuck here]

  • Error in Invoking target "client_sharedlib" of makefile '<path>/product/11.2.0/db_1/rdbms/lib/ins_rdbms.mk'.

Stuck here. Please help.

List of other packages getting failed:

  • libaio-0.3.105
  • compat-libstdc++-33-3.3.3
  • compat-libstdc++-33-3.3.3 (twice)
  • libaio-devel-0.3.105
  • libgcc-3.4.6
  • libstdc++-3.4.6
  • unixODBC-2.2.11
  • unixODBC-devel-2.2.11
  • pdksh-5.2.14

Exact versions:

  • OracleDB: Oracle Database 11g Release 2 (11.2.0)
  • RHEL: 3.10.0-123.el7.x86_64 - Red Hat Enterprise Linux Server release 7.0 (Maipo)

migrated from stackoverflow.com Jul 22 '15 at 0:29

This question came from our site for professional and enthusiast programmers.

  • Added the link. OracleDB: Oracle Database 11g Release 2 (11.2.0) and RHEL: 3.10.0-123.el7.x86_64 - Red Hat Enterprise Linux Server release 7.0 (Maipo) – Prabhu R Jul 6 '15 at 6:32
  • Oops! 11g link I followed is here. docs.oracle.com/cd/E11882_01/install.112/e24326/… – Prabhu R Jul 6 '15 at 6:33
  • According to the documentation 11g is supported on RHEL 4 and RHEL 5. If you want 11g you'll need to install an older version of the OS, or do a lot of Linux hacking. Alternatively you could install Oracle 12c, which is supported on RHEL 7 (11g is now an unsupported version, although I appreciate that probably doesn't bother you). – APC Jul 6 '15 at 6:39
  • But as per the link I shared, it says possible to install on RHEL 7 right ? – Prabhu R Jul 6 '15 at 6:50
  • @APC, For 11g on RHEL7, it must be 11.2.0.4. However, I would go for 12c rather than 11g. – Lalit Kumar B Jul 6 '15 at 7:04
1

From My Oracle support, Doc ID 1304727.1

Red Hat Enterprise Linux 7 - 11.2.0.4 only

  • Oracle Unbreakable Enterprise Kernel:3.8.13-35.3.1.el7uek.x86_64 or higher
  • Red Hat compatible kernel: 3.10.0-123.el7.x86_64 or higher

So, unless you are installing 11.2.0.4, you will have compatibility issues on RHEL7. Either install 11.2.0.4 and up on RHEL7, or use a lower compatible version.

More information:

Red Hat Enterprise Linux 6.x - Database 11.2.0.3 and higher

  • Red Hat kernel 2.6.32-71.el6.x86_64 or later
  • Oracle Unbreakable Enterprise Kernel (UEK R1) 2.6.32-100.28.5.el6.x86_64 or later
  • So, does WCS 11.1.1.8.0 on WLS 10.3.6.0 supported by 12c DB ? – Prabhu R Jul 6 '15 at 8:20
  • @PrabhuR Could you please elaborate, I didn't get you. – Lalit Kumar B Jul 6 '15 at 8:26
  • If I install 12c version, will WebCenterSites on WebLogic Server be supportive? – Prabhu R Jul 6 '15 at 8:27
  • @PrabhuR But how is this related to your original question? You should post a new question for weblogic server related. I have 12c installed on OEL7, I have no issues with weblogic, everything works fine. – Lalit Kumar B Jul 6 '15 at 8:28
  • I tried 11.2.0.4 version. Package checks went fine. But I am getting this error while installing: "Error in Invoking target "client_sharedlib" of makefile '<path>/product/11.2.0/db_1/rdbms/lib/ins_rdbms.mk' ". Please help. – Prabhu R Jul 6 '15 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy