2

When I try to install PostgreSQL 9.4.+ on Ubuntu, it is installing version 9.3.9. I have used the following command:

sudo apt-get install postgresql postgresql-contrib

Then I have tried with sudo apt-get install postgresql-9.4. But that gave me an error like "package not found".

How can I install 9.4 on Ubuntu?

Distribution details:

  • Distributor ID: Ubuntu
  • Description: Ubuntu 14.04 LTS
  • Release: 14.04
  • Codename: trusty
0

1 Answer 1

6

14.04 shipped with PostgreSQL 9.3, so that's what you're going to get if you use Ubuntu's repositories.

If you want PostgreSQL 9.4 or newer releases you need to add a 3rd party package repository, like the official PostgreSQL repositories from http://apt.postgresql.org/ . See the instructions there for details.

(You should also probably read https://help.ubuntu.com/community/PostgreSQL)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.