2

I have problems connecting computers running Windows 7 to a database SQL Server 2014 Express intermittently.

It happens that, intermittently, I can not connect to the database that is on a Windows 2008 R2 server.

If I restart the computer, works again, but only for a few minutes, sometimes hours.

The Firewall of my computer is turned off. Windows Firewall is turned off.

CONFIGURATION:

  • The server is Windows Server 2008 R2 Foundation
  • Firewall Ports TCP / IP and UDP 1434 1433 allowed

SQL Server Express:

  • Unlimited Connections
  • Allows remote connections
  • Timeout remotely query: 600 seconds

Machines with Windows XP have no problem with this issue.

1

Finally, it seems to have turned the problem: an IP in the secondary DNS configuration caused the problem. Removing the IP, everything works correctly again.

-1

Make sure your power settings are not set to hibernate or sleep on the client PC's (Check ALL power option settings, place a value of '0' for 'Never'). Typically if the machine goes to sleep, the ODBC connection to the DB gets lost. That is why 'restarting' will work, and the time frame varies from a few minutes to a few hours.

Also, make sure you have both ODBC 32 bit and 64 bit configured for your DB.

Typically located on... c:\windows\syswow64\odbcad32.exe but easily accessible in Control Panel under Administrative tools.

I hope this helps you solve your issue. It certainly could be a cause of the issue described, feel free to add on to this issue if my solution does not resolve your issue.

  • The power settings are in not hibernate nor sleep status. – eduard Jul 29 '15 at 7:24
  • ODBC Drivers: 32 and 64 bits installed. – eduard Jul 29 '15 at 7:25
  • If I keep an application running constantly, the problem does not appear. I can run other applications connecting databases without error. May be any relation with number of users/threads? – eduard Aug 25 '15 at 9:44
  • I'm sorry, the above is not correct. I have found that also fails even if other programs connected to the bd working properly. – eduard Aug 25 '15 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.