1

Following a reboot, two of our databases were marked as “Recovery Pending” and could not be accessed. These databases are both using FILESTREAM. In trying to fix them, we attempted the following:

  • Take the database offline (“could not take database offline”)
  • Detach the database (Database cannot be accessed because it is in recovery)
  • After several hours, tried restoring the database. It refused because the database was in use, so we dropped the database, and tried to restore.

It then told us that FILESTREAM was not enabled on the instance. Sure enough, it was gone. The problem is, we can’t turn it back on.

Every time we do, we get the following dialog message:

There was an unknown error applying the FILESTREAM settings. Check the parameters are valid. (0x80070002)

In the Event log, we have this message:

FILESTREAM feature configuration might be inconsistent. To reset the configuration, use the sp_configure stored procedure.

The following succeeds…

exec sp_configure 'filestream access level', 2;
reconfigure;

…but, the value doesn’t change.

name                    minimum maximum config_value    run_value
filestream access level 0             2            2            0
  • have you tried resetting filestream access level to zero? exec sp_configure 'filestream access level', 0; reconfigure; then resetting it to 2? – Max Vernon Jul 29 '15 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.